Bug 3125 - samba 3.??? is not compatible with the OS/2 GUI
samba 3.??? is not compatible with the OS/2 GUI
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0
Other OS/2
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-29 18:12 UTC by Pete
Modified: 2005-10-11 14:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pete 2005-09-29 18:12:14 UTC
I use a Linksys NSLU2 which is an embedded linux device. This device enables the
use of a USB hard drive as Network Attached Storage.

I recently updated the firmware in the NSLU2. The updated firmware includes
samba v3. something.

While I can still connect to the USB drive attached to the NSLU2 using a command
line I cannot access it using the OS/2 "File and Print Client" graphical interface.

Whatever has changed in samba results in the following error messages when I try
to open a shared folder using the File and Print Client interface:-
"No objects were found that match the search criteria" followed by "The system
call level is incorrect".

The previous NSLU2 firmware was using samba 2.?? and worked OK as regards File
and Print Client access - won't say much about other aspects of the earlier
firmware  :-)

Any chance of getting samba working properly in the near future? - then I have
to get Linksys to update the firmware again.

Thanks

Pete
Comment 1 Gerald (Jerry) Carter 2005-09-29 18:38:51 UTC
Can you reproduce this against a stock 3.0.20a build?
We can't really debug Linysys firmware, but if yuo can 
reproduce it against a plain build, then we can work on it.
Comment 2 Marcel Müller 2005-10-07 07:35:13 UTC
I probably fixed all these issues concerning File services with Jeremy about
release 3.0.16.
So 3.0.20a shold work fine.
Comment 3 Gerald (Jerry) Carter 2005-10-11 07:46:48 UTC
closing
Comment 4 Pete 2005-10-11 14:10:57 UTC
I have not tried samba 3.0.20a myself - the difficulty of getting Linksys to
upgrade the samba used in the firmware of the NSLU2.

I have done the next best thing and asked those OS/2 and eCS users that also use
samba somewhere to test 3.0.20a - they all knew exactly what to test for.

The response was Positive, samba3.0.20a works Fine.

Thank You for your help.

Pete