Bug 3120 - winbindd panic without any core
winbindd panic without any core
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.20
Sparc Solaris
: P3 critical
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-28 00:37 UTC by stephan theiler
Modified: 2005-09-29 09:32 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stephan theiler 2005-09-28 00:37:16 UTC
log.winbindd
[2005/09/28 04:30:01, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2005/09/28 04:30:01, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 13673 (3.0.20)
  Please read the appendix Bugs of the Samba HOWTO collection
[2005/09/28 04:30:01, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2005/09/28 04:30:01, 0] lib/util.c:smb_panic2(1548)
  PANIC: internal error



log.smbd
[2005/09/25 16:13:36, 2] lib/dmallocmsg.c:register_dmalloc_msgs(71)
  Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
[2005/09/25 16:13:36, 2] smbd/server.c:open_sockets_smbd(330)
  waiting for a connection
[2005/09/28 07:40:02, 2] smbd/server.c:exit_server(608)
[2005/09/28 07:40:02, 2] smbd/server.c:exit_server(608)
  Closing connections
  Closing connections


Our smb.conf

# Configuration file for smbd for appdsrv/appisrv.
# created by Team ITU / ths , 21.07.04
#---------------------------------------------------------------
#
#
[global]
; workgroup = NT-Domain-Name or Workgroup-Name, eg: WORKGROUP
  workgroup = ISURFAD

; comment is the equivalent of the NT Description field
  comment = Samba Server

; samba uses a guest account
;   guest account = nobody

; not necessary with NT-Clients but for WFW clients
;   password level = 0

; The next option sets a separate log file for each client. Remove
; it if you want a combined log file.
   log file = /var/log/css/samba/log.%m
   log level = 2
; Put a capping on the size of the log files (in Kb)
   max log size = 500


; Security and file integrity related options
   lock directory = /var/log/css/samba/locks
   locking = yes

; Files can be shared
   share modes = yes

; Interface Setttings for failover Configuration

smb ports = 139

bind interfaces only = true
interfaces = 193.247.124.169/255.255.255.224


;this will see the following string in the browser
   server string = Windows 3007 Server Galaxy Edition

;  security = domain -> Server is part of the domain CSS
   realm = ms.isurfad.css.ch
   security = ads
   password server =  pcs90947.ms.isurfad.css.ch

; "security = domain" requires "encrypt passwords = true"
  encrypt passwords = true

  obey pam restrictions = yes

;this sets the NetBIOS name by which a Samba server is known
   netbios name = homeisrv

;definition of the WINS server; change it later to correct alias
;  wins server = winssrv
;
; Winbind Definitionen
;idmap backend = ads
winbind use default domain = yes
idmap uid = 20000-30000
winbind gid = 20000-30000
winbind enum users = yes
winbind enum groups = yes
winbind cache time = 600
;winbind nss info = sfu

;
template homedir = /home/%u
template shell = /bin/ksh
;
; no printers will be loaded on this host
  load printers = no

; clients without open files will be disconnect after 15 min and the ressources
; a client does an automatic reconnect when accessing the share
   dead time = 15

; Check every 120 sec if the socket is still active
keep alive = 120

; enable oplock requests; there's no need to activate it in this file
; it's already activated (default value)
;  fake oplocks = no
;  oplocks = yes
;  getwd cache = yes
;  wide links = no
;don't become local master browser
local master = no

;        large readwrite = yes
        case sensitive = No
        preserve case = No
        default case = lower
        unix charset = CP850
        display charset = CP850
;       unicode = no
;       dos charset = CP850

; set the resolve order for Netbios name queries
name resolve order = host bcast

; show just the server specific shares
;include = /tools/samba/current/lib/smb.conf.%L

; Homes
[homes]
   comment = Home Directories
   browseable = no
   read only = no
   create mask = 0664
   security mask = 0
   force security mode = 0664
   directory mask = 2775
   force directory mode = 2775
   directory security mask = 0
   force directory security mode = 2775

; Special Entries
[ntprofi]
   copy = homes
   comment = NT User Profiles
   path = /home/ntprofi
Comment 1 Volker Lendecke 2005-09-28 04:01:45 UTC
Is the snippet of the log.winbindd really everything? If you can reproduce this
crash, could you please post a full debug level 10 log?

There have been AMD64-bit related fixes for winbind which could theoretically
also apply for Sparc. Could you try all the recommended patches from
http://www.samba.org/samba/patches/? Or if you don't want to manually patch
Samba, you could wait for 3.0.20a which is due within the next 2 weeks.

Please report if any of the recommended patches fixes your problem.

Thanks,

Volker
Comment 2 Gerald (Jerry) Carter 2005-09-28 09:44:14 UTC
Stephan, please keep comments in bugzilla rather than email:

> Yes that is the only thing that i have seen on the system. 
> One more Infomation, there was no Load on the System and also 
> no logged in Users at this time.
Comment 3 Volker Lendecke 2005-09-28 23:29:57 UTC
Sorry, but those few lines are not enough information to track this down. You
did not say whether this only happened once or if it's reproducable. And, did
you try the patches from the URL I posted?

Volker
Comment 4 Gerald (Jerry) Carter 2005-09-29 09:32:06 UTC
closing as per commentsk from Stephan:

> I have installed your Patches and at the moment it 
> works fine. I can't reproduce the Event, then it 
> happens only once