Bug 3102 - Shared library build problem?
Shared library build problem?
Status: RESOLVED DUPLICATE of bug 3717
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.20
PPC AIX
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-15 06:07 UTC by Johan
Modified: 2006-04-24 10:38 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johan 2005-09-15 06:07:29 UTC
Hi,
                                                                               
           
When building samba 3.0.20 on AIX 5.3 the following error occurs:              
                                                                            

configure:
                                                                               
           
./configure --prefix=/opt/compiled \
--with-ads \
--with-krb5=/opt/compiled \
--with-libiconv=/opt/compiled \
--with-winbind \
--with-ldap=/opt/compiled \
--with-pam \
--config-cache \
--with-aio-support
                                                                               
           
<snip>
checking ability to build shared libraries... true
checking linker flags for shared libraries... -Wl,-bexpall,-bM:SRE,-bnoentry,-berok
checking compiler flags for position-independent code... -O2
checking whether building shared libraries actually works... cc: 1501-218 file
shlib.po contains an incorrect file suffix
yes
<snip>
                                                                               
           
make:
                                                                               
           
<snip>
Linking nsswitch/WINBIND
cc: 1501-218 file nsswitch/wb_common.po contains an incorrect file suffix
cc: 1501-218 file lib/replace1.po contains an incorrect file suffix
cc: 1501-218 file nsswitch/winbind_nss_aix.po contains an incorrect file suffix
cc: 1501-218 file lib/snprintf.po contains an incorrect file suffix
Compiling nsswitch/pam_winbind.c with -O2
"nsswitch/pam_winbind.c", line 71.43: 1506-280 (W) Function argument assignment
between types "void**" and "const void**" is not allowed.
"nsswitch/pam_winbind.c", line 73.36: 1506-280 (W) Function argument assignment
between types "struct pam_message**" and "const struct pam_message**" is not
allowed.
"nsswitch/pam_winbind.c", line 89.20: 1506-068 (W) Operation between types
"char*" and "const char*" is not allowed.
"nsswitch/pam_winbind.c", line 329.59: 1506-280 (W) Function argument assignment
between types "void**" and "const void**" is not allowed.
"nsswitch/pam_winbind.c", line 341.32: 1506-045 (S) Undeclared identifier
PAM_AUTHTOK_RECOVER_ERR.
"nsswitch/pam_winbind.c", line 362.36: 1506-068 (W) Operation between types
"char*" and "const char*" is not allowed.
"nsswitch/pam_winbind.c", line 370.30: 1506-068 (W) Operation between types
"char*" and "const char*" is not allowed.
"nsswitch/pam_winbind.c", line 376.38: 1506-068 (W) Operation between types
"char*" and "const char*" is not allowed.
"nsswitch/pam_winbind.c", line 434.40: 1506-280 (W) Function argument assignment
between types "void**" and "const void**" is not allowed.
"nsswitch/pam_winbind.c", line 451.1: 1506-277 (S) Syntax error: possible
missing ';' or ','?
"nsswitch/pam_winbind.c", line 454.25: 1506-277 (S) Syntax error: possible
missing ';' or ','?
"nsswitch/pam_winbind.c", line 459.15: 1506-277 (S) Syntax error: possible
missing ';' or ','?
"nsswitch/pam_winbind.c", line 448.1: 1506-485 (S) Parameter declaration list is
incompatible with declarator for PAM_EXTERN.
"nsswitch/pam_winbind.c", line 464.13: 1506-045 (S) Undeclared identifier ctrl.
"nsswitch/pam_winbind.c", line 469.6: 1506-273 (E) Missing type in declaration
of retval.
"nsswitch/pam_winbind.c", line 471.39: 1506-045 (S) Undeclared identifier password.
"nsswitch/pam_winbind.c", line 469.38: 1506-045 (S) Undeclared identifier pamh.
"nsswitch/pam_winbind.c", line 469.44: 1506-045 (S) Undeclared identifier ctrl.
"nsswitch/pam_winbind.c", line 469.15: 1506-221 (S) Initializer must be a valid
constant expression.
"nsswitch/pam_winbind.c", line 473.6: 1506-046 (S) Syntax error.
make: 1254-004 The error code from the last command is 1.
                                                                               
           
                                                                               
           
Stop.
<snip>                                                                         
                 

Compiler used:
IBM XL C/C++ Enterprise Edition V7.0                                           
                                               

If you need any additional information I'll be glad to provide it to you.
                                                                               
           
Best regards,
                                                                               
           
Johan Söderberg
Comment 1 Claus Lund 2005-12-20 13:48:36 UTC
I am seeing the same on AIX5.2 and AIX5.3 using v.6.0 of IBM's compiler (with the latest updates).

Things work if you use gcc...
Comment 2 Gerald (Jerry) Carter 2006-04-20 08:03:35 UTC
severity should be determined by the developers and not the reporter.
Comment 3 Björn Jacke 2006-04-24 10:38:52 UTC
this is also being fixed by the patch from #3717

*** This bug has been marked as a duplicate of 3717 ***