Bug 3097 - Missing files in directory listing
Missing files in directory listing
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.20
All AIX
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-14 05:48 UTC by Walter Muehlbauer
Modified: 2005-09-20 04:17 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Muehlbauer 2005-09-14 05:48:13 UTC
Samba 3.0.20 on AIX 5.2.0.0 built with gcc 3.3.2
PC: XP SP2

Some files of directories containing many files are not dispayed in the 
explorer listing.

Suppose 500 files named A00001 to A00500 in one directory on the AIX server. 
Files A00150, A00302 and A00454 are not displayed in windows explorer. The 
number of files shown in windows is 497 instaed of 500. Successively reducing 
the number of files, the number of missing files decreases. In this particular 
case 149 files (A00001 to A00149) were all displayed. Adding a 150-th file with 
an arbitrary name, this file is not displayed. Then renaming file A00149, the 
new file name is not displayed but the file added before is now to be seen. 
Crazy, isn't it?

The problem is of random nature. There is another directory containing 300 
files and no file is missing. It seems to depend on the number of files within 
a directory and the variety of the file names.
Comment 1 Gerald (Jerry) Carter 2005-09-14 06:23:46 UTC
please see the patches at http://www.samba.org/samba/patches/
This should be fixed now.
Comment 2 Walter Muehlbauer 2005-09-16 01:47:50 UTC
Thank's for the quick response.
There are several patches at http://www.samba.org/samba/patches/. The attempt 
to install one of these patches by means of the patch command as described in 
the obove link failed (error: no patch exists). Is there a detailed description 
who to apply the patches?
Probably one specific patch resolves the problems described here. So I need not 
to install all available patches. What particular patch is this?
Comment 3 Walter Muehlbauer 2005-09-20 02:28:27 UTC
(In reply to comment #1)
> please see the patches at http://www.samba.org/samba/patches/
> This should be fixed now.

Thank's for the quick response.
There are several patches at http://www.samba.org/samba/patches/. The attempt 
to install one of these patches by means of the patch command as described in 
the obove link failed (error: no patch exists). Is there a detailed description 
how to apply the patches?
Probably one specific patch resolves the problems described here. So I need not 
to install all available patches. What particular patch is it?
Comment 4 Gerald (Jerry) Carter 2005-09-20 04:17:16 UTC
There will be a 3.0.20a release later this week.  If 
you are havnig trouble with the individual patches, then it might 
be better to wait for the new release.