Bug 3074 - Thousands of smbd processes stuck in FUTEX_WAIT
Thousands of smbd processes stuck in FUTEX_WAIT
Status: RESOLVED DUPLICATE of bug 3073
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.20
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-08 14:35 UTC by Dax Kelson
Modified: 2005-09-27 14:57 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dax Kelson 2005-09-08 14:35:25 UTC
On a FC4 box I upgraded to Samba 3.0.20 and started using the new ability to
authenticate against a MIT Kerberos KDC.

Part of my config:

   workgroup = GURULABS
   realm = GURULABS.COM
   use kerberos keytab = yes
   log level = 3 passdb:5 auth:10

It *seems* to be working great from the client perspective. The client is a
single Windows 2003 Terminal Server with 5 or so users. The Windows Terminal
Server is authenticating against the same MIT Kerberos KDC (v1.4.2).

On the server though, I have many thousand smbd processes. Observe:
# ps auxw | grep "[s]mbd -D" | wc -l
2445

When I strace one of them, I get:

# strace -fp 1296
Process 1296 attached - interrupt to quit
futex(0x8c8880, FUTEX_WAIT, 2, NULL

Here are the last 50 lines of my smbd.log file:

[2005/09/08 15:33:18, 3] smbd/reply.c:reply_echo(3499)
  echo 1 times
[2005/09/08 15:33:18, 3] smbd/reply.c:reply_echo(3499)
[2005/09/08 15:33:18, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  echo 1 times
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2005/09/08 15:33:18, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[root@mooru samba]# tail -20 log.smbd
[2005/09/08 15:33:49, 3] smbd/process.c:process_smb(1114)
[2005/09/08 15:33:49, 3] smbd/process.c:process_smb(1114)
  Transaction 2893 of length 53
  Transaction 20509 of length 53
[2005/09/08 15:33:49, 3] smbd/process.c:switch_message(900)
[2005/09/08 15:33:49, 3] smbd/process.c:switch_message(900)
  switch message SMBecho (pid 1245) conn 0x0
  switch message SMBecho (pid 30454) conn 0x0
[2005/09/08 15:33:49, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2005/09/08 15:33:49, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2005/09/08 15:33:49, 3] smbd/reply.c:reply_echo(3499)
  echo 1 times
[2005/09/08 15:33:49, 3] smbd/reply.c:reply_echo(3499)
[2005/09/08 15:33:49, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  echo 1 times
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2005/09/08 15:33:49, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[root@mooru samba]#
[root@mooru samba]# tail -50 log.smbd
[2005/09/08 15:32:48, 3] smbd/reply.c:reply_echo(3499)
  echo 1 times
[2005/09/08 15:32:48, 3] smbd/reply.c:reply_echo(3499)
  echo 1 times
[2005/09/08 15:32:48, 3] smbd/sec_ctx.c:set_sec_ctx(288)
[2005/09/08 15:32:48, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2005/09/08 15:33:01, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2005/09/08 15:33:18, 3] smbd/process.c:process_smb(1114)
[2005/09/08 15:33:18, 3] smbd/process.c:process_smb(1114)
  Transaction 20508 of length 53
  Transaction 2892 of length 53
[2005/09/08 15:33:18, 3] smbd/process.c:switch_message(900)
[2005/09/08 15:33:18, 3] smbd/process.c:switch_message(900)
  switch message SMBecho (pid 30454) conn 0x0
  switch message SMBecho (pid 1245) conn 0x0
[2005/09/08 15:33:18, 3] smbd/sec_ctx.c:set_sec_ctx(288)
[2005/09/08 15:33:18, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2005/09/08 15:33:18, 3] smbd/reply.c:reply_echo(3499)
  echo 1 times
[2005/09/08 15:33:18, 3] smbd/reply.c:reply_echo(3499)
[2005/09/08 15:33:18, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  echo 1 times
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2005/09/08 15:33:18, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2005/09/08 15:33:49, 3] smbd/process.c:process_smb(1114)
[2005/09/08 15:33:49, 3] smbd/process.c:process_smb(1114)
  Transaction 2893 of length 53
  Transaction 20509 of length 53
[2005/09/08 15:33:49, 3] smbd/process.c:switch_message(900)
[2005/09/08 15:33:49, 3] smbd/process.c:switch_message(900)
  switch message SMBecho (pid 1245) conn 0x0
  switch message SMBecho (pid 30454) conn 0x0
[2005/09/08 15:33:49, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2005/09/08 15:33:49, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2005/09/08 15:33:49, 3] smbd/reply.c:reply_echo(3499)
  echo 1 times
[2005/09/08 15:33:49, 3] smbd/reply.c:reply_echo(3499)
[2005/09/08 15:33:49, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  echo 1 times
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2005/09/08 15:33:49, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
Comment 1 Gerald (Jerry) Carter 2005-09-27 12:21:53 UTC
What is the status of the processes shown by `ps`?
Comment 2 Dax Kelson 2005-09-27 14:57:40 UTC
I upgraded e2fsprogs to version 1.38 and the problem went away.

See: https://bugzilla.samba.org/show_bug.cgi?id=3073

*** This bug has been marked as a duplicate of 3073 ***