Bug 3051 - File Name ending With a Dot
File Name ending With a Dot
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.20
x86 All
: P3 normal
: none
Assigned To: Jeremy Allison
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-29 09:55 UTC by Andre Rolino
Modified: 2005-08-30 08:56 UTC (History)
0 users

See Also:


Attachments
Share Listing (124.01 KB, image/jpeg)
2005-08-29 09:57 UTC, Andre Rolino
no flags Details
SMB Share listing using Konqueror (253.07 KB, image/png)
2005-08-30 07:36 UTC, Andre Rolino
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andre Rolino 2005-08-29 09:55:54 UTC
I am using the samba as serving of archives of my network.

The archives with the name finished with a dot(".") are not shown
correctly when had access for the sharing.

Local filenames:

88.
90.
92.
94.

Using the samba share:

86SIL4~A
92MLE7~Y
92WKZV~1
93GK7A~F

Screenshot here:

http://projetos.unimetalcoque.com.br/arquivos/fotos/samba.jpg

Thanks!
Comment 1 Andre Rolino 2005-08-29 09:57:11 UTC
Created attachment 1409 [details]
Share Listing
Comment 2 Gerald (Jerry) Carter 2005-08-29 10:28:32 UTC
please retest against 3.0.20 and reopen if the bug is still present.
Comment 3 Andre Rolino 2005-08-30 07:36:44 UTC
Created attachment 1410 [details]
SMB Share listing using Konqueror
Comment 4 Andre Rolino 2005-08-30 07:37:13 UTC
Using samba 3.0.20 version the problem persists.
Comment 5 Gerald (Jerry) Carter 2005-08-30 07:54:17 UTC
I think this is actually by design now that I look closer at 
your report.  IIRC Windows cannot handle filenames ending in 
a dot.  So the name has to be mangled.  

Jeremy, can you confirm ?
Comment 6 Jeremy Allison 2005-08-30 08:56:06 UTC
Indeed Windows will not handle names ending in dot. If you try and create one it
silently truncates it. So we must mangle such names.
Jeremy.