Bug 3048 - 3.0.20 compiles in aio support on aix by default, and when asked not to
3.0.20 compiles in aio support on aix by default, and when asked not to
Status: RESOLVED DUPLICATE of bug 3340
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.20
PPC AIX
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 22:06 UTC by J Raynor
Modified: 2006-03-26 11:28 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J Raynor 2005-08-26 22:06:39 UTC
I'm trying to install samba-3.0.20 on aix 5.2, and I don't want to use aio, but
the build process is compiling it in anyway.  By default, it isn't supposed to
build in aio support, but it does.  When I pass --with-aio-support=no to
configure, it also builds in support.  It builds in aio support whether I use
gcc or xlc.

Here's what ldd shows:

# ldd bin/smbd
bin/smbd needs:
         /usr/lib/libc.a(shr.o)
         /usr/lib/libc.a(posix_aio.o)
         /usr/lib/librtl.a(shr.o)
         /unix
         /usr/lib/libcrypt.a(shr.o)
Comment 1 Bernd FLUNGER 2005-09-08 09:06:28 UTC
(In reply to comment #0)
> I'm trying to install samba-3.0.20 on aix 5.2, and I don't want to use aio, but
> the build process is compiling it in anyway.  By default, it isn't supposed to
> build in aio support, but it does.  When I pass --with-aio-support=no to
> configure, it also builds in support.  It builds in aio support whether I use
> gcc or xlc.
> 
> Here's what ldd shows:
> 
> # ldd bin/smbd
> bin/smbd needs:
>          /usr/lib/libc.a(shr.o)
>          /usr/lib/libc.a(posix_aio.o)
>          /usr/lib/librtl.a(shr.o)
>          /unix
>          /usr/lib/libcrypt.a(shr.o)

had the same problem,
adding CFLAGS=-D_AIO_AIX_SOURCE 
to configure command solves the problem

(e.g.: ./configure --with-aio-support=no CFLAGS=-D_AIO_AIX_SOURCE)
Comment 2 William Jojo 2006-01-07 08:20:27 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > I'm trying to install samba-3.0.20 on aix 5.2, and I don't want to use aio, but
> > the build process is compiling it in anyway.  By default, it isn't supposed to
> > build in aio support, but it does.  When I pass --with-aio-support=no to
> > configure, it also builds in support.  It builds in aio support whether I use
> > gcc or xlc.
> > 
> > Here's what ldd shows:
> > 
> > # ldd bin/smbd
> > bin/smbd needs:
> >          /usr/lib/libc.a(shr.o)
> >          /usr/lib/libc.a(posix_aio.o)
> >          /usr/lib/librtl.a(shr.o)
> >          /unix
> >          /usr/lib/libcrypt.a(shr.o)
> had the same problem,
> adding CFLAGS=-D_AIO_AIX_SOURCE 
> to configure command solves the problem
> (e.g.: ./configure --with-aio-support=no CFLAGS=-D_AIO_AIX_SOURCE)

Although that does resolve the symptom, its not the correct fix. :-) Please see patch posted to 3340.

Cheers,

Bill
Comment 3 Gerald (Jerry) Carter 2006-01-09 08:37:33 UTC

*** This bug has been marked as a duplicate of 3340 ***