Bug 3036 - passdb backend configuration problem with included configfile
passdb backend configuration problem with included configfile
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
All Linux
: P3 minor
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-08-24 10:52 UTC by Andrzej Czajewski
Modified: 2006-04-09 11:12 UTC (History)
0 users

See Also:

main smb.conf (10.64 KB, text/plain)
2005-08-26 00:25 UTC, Andrzej Czajewski
no flags Details
included smb.loki.conf (1.32 KB, text/plain)
2005-08-26 00:26 UTC, Andrzej Czajewski
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrzej Czajewski 2005-08-24 10:52:22 UTC
I'n using samba 3.0.14a on FC4 and i've got 
problem with passdb backend creation during instalation:

I've got merely untouched smb.conf (comparig to disto-s) with smb.loki.conf
included at the last line.
All my settings are in smb.loki.conf including 
passdb backend = tdbsam .

With this smbpasswd and tdbedit didn't undestand that i wanted tdb backed 
and were creating smbpasswd instead of passdb.tdb and smb daemon was looking
for passdb.tdb causing errors in log file, and  authentication problems.

After moving passdb backend statement to main smb.conf everything worked fine.

For me looks like smbpasswd and pdbedit didn't read included configfile.

Andrzej Czajewski
Comment 1 Jelmer Vernooij 2005-08-24 11:15:47 UTC
Please include the smb.conf files in question. 

Is there a dot in your "passdb backend = " line or was that part of the sentence?
Comment 2 Andrzej Czajewski 2005-08-26 00:23:30 UTC
(In reply to comment #1)
No that was just sentence ending.

Both smb.conf and smb.loki.conf attached.
Now at line 21 in smb.conf there is passdb backend statement,
without it there ( it was still in smb.loki.conf ) the problem occured.

Comment 3 Andrzej Czajewski 2005-08-26 00:25:58 UTC
Created attachment 1406 [details]
main smb.conf

main smb conf from which smb.loki.conf
Comment 4 Andrzej Czajewski 2005-08-26 00:26:38 UTC
Created attachment 1407 [details]
included smb.loki.conf
Comment 5 Volker Lendecke 2006-04-09 11:12:38 UTC
Just tried it with latest 3_0. Works for me.

Please retry with a later version. If the problem persists, please provide a minimal smb.conf (should be doable in very few lines).