Bug 3032 - similar to problem already registered but on other versions
similar to problem already registered but on other versions
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
3.0.20
PPC AIX
: P3 regression
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-24 00:39 UTC by Costas Mardacofta
Modified: 2005-08-24 05:16 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Costas Mardacofta 2005-08-24 00:39:21 UTC
I am trying to install Samba 3.0.20 on AIX 4.3.3 and I get the error :

/usr/local/samba/sbin>./nmbd -V                                         
exec(): 0509-036 Cannot load program ./nmbd because of the following errors:    
        0509-150   Dependent module /usr/lib/libiconv.a(libiconv.so.2) could not
 be loaded.                                                                     
        0509-152   Member libiconv.so.2 is not found in archive                 

I have done a search on the net and a lot of people seem to be faced with the
same  problem. libiconv.a exists in the /usr/lib of my machine.

The version used is the compiled one from the Bull freeware site.

Initially there were errors reference to the libldap library, and by installing the:
bos.net.tcp.server
bos.net.tcp.client
bos.mp
bos.up
perfagent.tools

very latest versions this error dissappeared. I have tried checking for the
libconv.a but this is the latest one for AIX 4.3.3, so it should be ok.

Any ideas as this is blocking the installation of the product. Also there is no
smb.conf file created by default.

Thank you for any feedback.
Comment 1 Gerald (Jerry) Carter 2005-08-24 05:16:01 UTC
This is not a Samba bug.  This is an issue with the bull 
freeware packages.  You'll have to talk to the maintainer 
of that package.