Bug 3026 - Cannot connect to samba-3.0.x from XP SP2 client
Cannot connect to samba-3.0.x from XP SP2 client
Product: Samba 3.0
Classification: Unclassified
Component: File Services
x86 Windows XP
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-08-22 19:14 UTC by David Billinghurst
Modified: 2005-10-12 13:04 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description David Billinghurst 2005-08-22 19:14:04 UTC
I am running a RHEL3 x86_64 server with samba-3.0.x, x={9,14,20}
with security=server.

I can connect to this server using win2k clients and samba smbclient.
I can't connect from winXP SP2 clients.

When I installed samba-2.2.12 on th server, and use the same smb.conf 
file, I can connect from winXP SP2 clients.

More details, and level 2 logs, provided:
 - http://lists.samba.org/archive/samba/2005-August/109727.html
 - http://lists.samba.org/archive/samba/2005-August/109861.html
 - http://lists.samba.org/archive/samba/2005-August/109863.html
Comment 1 Gerald (Jerry) Carter 2005-09-28 07:28:29 UTC
I would really recommend testing 'security = domain'.
You might also want to disable spnego in smb.conf
as an additional test for 'security = server' (which has 
been deprecated btw).

Comment 2 Gerald (Jerry) Carter 2005-10-12 13:04:22 UTC
closing due to deprecated nature of security=server.