Bug 3025 - Failed to open /etc/samba/secrets.tdb
Failed to open /etc/samba/secrets.tdb
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.20
All Linux
: P3 regression
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-22 12:14 UTC by Giuliano Catrambone
Modified: 2005-08-29 08:29 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giuliano Catrambone 2005-08-22 12:14:37 UTC
I'm using Fedora CR4 and when I starts the smb service I get the following message:
"smb failed. The error was: Shutting down SMB services: [FAILED]

Shutting down NMB services: [FAILED]

Starting SMB services: [FAILED]

Starting NMB services: [  OK  ]
"

Therefore the /var/log/samba/log.smbd log file contains:
[2005/08/22 21:00:03, 0] smbd/server.c:main(802)
  smbd version 3.0.20 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2004
[2005/08/22 21:00:03, 0] passdb/secrets.c:secrets_init(64)
  Failed to open /etc/samba/secrets.tdb
[2005/08/22 21:00:03, 0] passdb/secrets.c:secrets_init(64)
  Failed to open /etc/samba/secrets.tdb
[2005/08/22 21:00:03, 0] passdb/secrets.c:secrets_init(64)
  Failed to open /etc/samba/secrets.tdb
[2005/08/22 21:00:03, 0] passdb/machine_sid.c:pdb_generate_sam_sid(163)
  pdb_generate_sam_sid: Failed to store generated machine SID.
[2005/08/22 21:00:03, 0] lib/util.c:smb_panic2(1548)
  PANIC: Could not generate a machine SID

[2005/08/22 21:00:03, 0] lib/util.c:smb_panic2(1556)
  BACKTRACE: 7 stack frames:
   #0 smbd(smb_panic2+0x8a) [0x4f49a2]
   #1 smbd(smb_panic+0x19) [0x4f4bee]
   #2 smbd(get_global_sam_sid+0x2e3) [0x4a84d3]
   #3 smbd(init_guest_info+0x65) [0x53acac]
   #4 smbd(main+0x2b8) [0x57ee84]
   #5 /lib/libc.so.6(__libc_start_main+0xc6) [0xb56de6]
   #6 smbd [0x35a121]

Could you tell me which is the problem?
thanks
  giu
Comment 1 Giuliano Catrambone 2005-08-26 00:09:37 UTC
Hi,
Since the log says that can not open the /etc/samba/secrets.tdb file,
I just moved it in /etc/samba/secrets.tdb.ori.
In that way, Samba give me an other message on the log:
[2005/08/26 09:07:12, 0] smbd/server.c:main(802)
  smbd version 3.0.20 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2004
[2005/08/26 09:07:12, 0] groupdb/mapping.c:init_group_mapping(134)
  Failed to open group mapping database
[2005/08/26 09:07:12, 0] groupdb/mapping.c:get_group_map_from_gid(275)
  failed to initialize group mapping
[2005/08/26 09:07:12, 0] lib/account_pol.c:init_account_policy(52)
  Failed to open account policy database
[2005/08/26 09:07:12, 0] lib/account_pol.c:init_account_policy(52)
  Failed to open account policy database
[2005/08/26 09:07:12, 0] lib/account_pol.c:init_account_policy(52)
  Failed to open account policy database
[2005/08/26 09:07:12, 0] lib/account_pol.c:init_account_policy(52)
  Failed to open account policy database
[2005/08/26 09:07:12, 0] lib/account_pol.c:init_account_policy(52)
  Failed to open account policy database
[2005/08/26 09:07:12, 0] lib/account_pol.c:init_account_policy(52)
  Failed to open account policy database
[2005/08/26 09:07:12, 0] lib/messages.c:message_init(106)
  ERROR: Failed to initialise messages database


On the Service Configuration window, where I launched the run of the smb service
I get the message:
smbd dead but pid file exists
nmbd (pid 4458) is running...

Could you help me to solve that issue.
thanks
giu
Comment 2 Gerald (Jerry) Carter 2005-08-29 08:29:50 UTC
This looks like a configuration issue and not a bug.  Please
mail the samba ml for genral help questions.