Bug 3023 - usrmgr.exe fail
usrmgr.exe fail
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.20
x86 Windows 2000
: P3 normal
: none
Assigned To: Jim McDonough
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-22 04:27 UTC by Artiom Makarov
Modified: 2005-09-06 15:38 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Artiom Makarov 2005-08-22 04:27:50 UTC
User managment by usrmgr.exe under Windows 2000 can't connect to domain.
"The procedure number out of range" error occure.
____
  check_ntlm_password:  authentication for user [tadmin] -> [tadmin] -> [tadmin]
succeeded
[2005/08/22 09:16:15, 0] rpc_parse/parse_prs.c:prs_mem_get(533)
  prs_mem_get: reading data of size 4 would overrun buffer.
[2005/08/22 09:16:15, 0] rpc_server/srv_pipe.c:api_rpcTNP(1572)
  api_rpcTNP: winreg: REG_CREATE_KEY_EX failed.
_____


FreeBSD 5.3, OpenLDAP 2.2.27, smbldap-tools-0.9

When downgradig back to 3.14a usrmgr work fine.
Comment 1 Artiom Makarov 2005-08-22 04:28:54 UTC
User managment by usrmgr.exe under Windows 2000 can't connect to domain.
"The procedure number out of range" error occure.
____
  check_ntlm_password:  authentication for user [tadmin] -> [tadmin] -> [tadmin]
succeeded
[2005/08/22 09:16:15, 0] rpc_parse/parse_prs.c:prs_mem_get(533)
  prs_mem_get: reading data of size 4 would overrun buffer.
[2005/08/22 09:16:15, 0] rpc_server/srv_pipe.c:api_rpcTNP(1572)
  api_rpcTNP: winreg: REG_CREATE_KEY_EX failed.
_____


FreeBSD 5.3, OpenLDAP 2.2.27, smbldap-tools-0.9

When downgradig back to 3.14a usrmgr work fine.
Comment 2 Gerald (Jerry) Carter 2005-08-30 05:36:05 UTC
user manage support needs an overhaul and some solid testing.  
This is on the plater for 3.0.21
Comment 3 Gerald (Jerry) Carter 2005-09-01 12:38:29 UTC
jmcd wants these.  So here you go.
Comment 4 Gerald (Jerry) Carter 2005-09-01 12:39:00 UTC
reopen
Comment 5 Jim McDonough 2005-09-06 15:38:38 UTC
Ok, this working for me on current svn for SAMBA_3_0.  Is it still failing for
you?  If so, please post a level 5 (minimum, perhaps level 10 if it's not too
big) log, and a tcpdump/ethereal trace of it starting up.