Bug 3012 - 8.3 names upcased when using Ghost 7.5 or 8
8.3 names upcased when using Ghost 7.5 or 8
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.20
All Windows XP
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-18 08:39 UTC by William Jojo
Modified: 2005-08-30 04:23 UTC (History)
0 users

See Also:


Attachments
log level 10 of ghost session. (293.26 KB, application/octet-stream)
2005-08-18 08:44 UTC, William Jojo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description William Jojo 2005-08-18 08:39:20 UTC
When Ghost creates an image file (.gho) the resulting 8.3 filename is all 
upper case regardless of the state of 'short preserve case' or 'default case'.
Comment 1 William Jojo 2005-08-18 08:44:14 UTC
Created attachment 1387 [details]
log level 10 of ghost session.
Comment 2 Jeremy Allison 2005-08-18 09:29:18 UTC
This may be due to the following code - needed for OS/2 in smbd/dir.c :

 /* We only uppercase if FLAGS2_LONG_PATH_COMPONENTS is zero in the input buf.
    Strange, but verified on W2K3. Needed for OS/2. JRA. */
 push_ascii(buf+30,fname,12, uc ? STR_UPPER : 0);

I could make this conditional on OS/2 - but it's not how W2K3 behaves.

Jeremy.
Comment 3 Jeremy Allison 2005-08-18 09:34:31 UTC
Yep - looking at the log this is definately the case.

Is this a show-stopper ? It's an easy fix, but makes us behave differently
than W2K3. I'm wondering what else it may break...

Jeremy.
Comment 4 William Jojo 2005-08-18 10:05:35 UTC
(In reply to comment #3)
> Yep - looking at the log this is definately the case.
> Is this a show-stopper ? It's an easy fix, but makes us behave differently
> than W2K3. I'm wondering what else it may break...
> Jeremy.

Certainly not a show stopper, just bothersome when moving objects around in 
AIX. Ok, I see it now. If I do "copy con: WINKY" and no extention, I can 
recreate it. So perhaps the work around for us is to not let ghost perform the 
extension-less search and we provide the extension from the get.
Comment 5 Jeremy Allison 2005-08-18 10:40:35 UTC
Jerry proposed making the "uppercase" bahaviour dependent on "short preserve
case" being False. The problem is we ship by default with "short preserve case =
True", so that means out of the box we won't do this the same as W2K3. Currently
the complaint about how we handle the names was from OS/2 - but I'm worried that
there are DOS apps that expect the same behaviour - it's specific enough that
W2K must have special code to do this (as we do now).
This is one of those conflicts with an option we have that conflicts with
"proper" Windows behaviour. I don't mind doing that if by default we ship with
"proper" Windows behaviour but in this case we'd be shipping broken by default.
Jeremy.
Comment 6 Gerald (Jerry) Carter 2005-08-30 04:23:52 UTC
The current behavior is correct according to Windows 
2003.  So we were previously broken.  Jeremy and I agreed 
that it is better to match the windows behavior.