Bug 298 - Always there is a mistake: Domain master node status fail
Always there is a mistake: Domain master node status fail
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
3.0.0preX
All Linux
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on: 310
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-14 23:30 UTC by Kirill
Modified: 2005-11-14 09:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kirill 2003-08-14 23:30:51 UTC
I have routed network with 3 segments. On each router was installed Linux with 
Samba (i try to use all versions from 2.2.6 to 3beta3). Workgroup is one. One 
server - domain master. The others - local master in subnetworks. Domain maser 
server also act as WINS (WINS configured on everything machines in networks).

When local master browsers try to call DMB:
[2003/08/15 10:29:15, 0] nmbd/nmbd_browsesync.c:domain_master_node_status_fail
(262)
  domain_master_node_status_fail:
  Doing a node status request to the domain master browser
  for workgroup COMNET at IP 192.168.4.1 failed.
  Cannot sync browser lists.

I try last half-year to find the decision of this problem.

DMB config:
-----------
[global]
        unix charset = KOI8-R
        display charset = KOI8-R
        dos charset = CP866
        workgroup = COMNET
        netbios name = COMMUN4
        server string = Samba Server %v
        log file = /var/log/samba/log.%m
        max log size = 50
        printcap name = cups
        os level = 64
        domain master = Yes
        local master = Yes
        wins support = Yes
        interfaces = eth1 192.168.4.1/16, lo 127.0.0.1/8
        bind interfaces only = Yes
        security = share
        name resolve order = lmhosts wins bcast host

LMB ñonfig:
------------
[global]

        netbios name = COMMUN2
        workgroup = COMNET
        security = share
        log level = 2
        log file = /var/log/samba/%m.log
        os level =64
        domain master = No
        preferred master = Yes
        local master = Yes
        name resolve order = lmhosts wins bcast host
        wins server = 192.168.4.1
        wins proxy = Yes
        interfaces = eth0 192.168.2.1/16,lo 127.0.0.1/8
        bind interfaces only = Yes
Comment 1 Abbott 2003-08-18 17:18:47 UTC
Here is the problem:
192.168.2.1/16 and 192.168.4.1/16 are on the same subnet.
You cannot have two local master browsers on the same subnet.
only one can be a master browser.
Your fix is to either 192.168.2.1/24 and 192.168.4.1/24.
or you can make one of them a master brower and not the other.
Comment 2 Kirill 2003-08-18 22:44:38 UTC
Yes, I know it. But... I have read all the documentation.
I tried ALL variants of settings (and yours), I searched in forums,
in manuals and is confident the words. As I already wrote,
I and many other people try to solve this problem.
Try to look in Google "Doing a node status request to
the domain master browser "

I by mistake have not described topology of my network.


(net1) - COMMUN4(router+WINS+LMB) - COMMUN2(route+LMB+DMB) - (net2)
   eth1(192.168.4.1)                                eth0(192.168.2.1)

So
> You cannot have two local master browsers on the same subnet.

The samba does not listen to external network interfaces.
For security reasons, it to do it is impossible. 

The problem is not solved :`( 
The samba does not work how is written to documentation (98-th year). 
Comment 3 Abbott 2003-08-19 19:02:33 UTC
You should check that broadcast is blocked from port 137 "netbios-ns" and 138
"netbios-dgm" or thos machines will kill each other over the browse election.

I have a network with 4 subnets "10.1.0.0/16" "10.2.0.0/16" "10.3.0.0/16" and
"10.4.0.0/16" linked by T1 connections with cisco routers in the middle.
I don't have any problems browsing the machines from any location.
Samba 2.2.8 as the only NT domain and dhcp server for all locations.
if you send me your current smb.conf and the network configuration for your
servers I'll be glad to check it for any misconfigurations.

I hope this helps.
Comment 4 Kirill 2003-08-19 22:58:43 UTC
Yes, broadcast is blocked. But why broadcast? Why broadcast so it is 
important? And if similar packages cannot pass, the samba cannot work at all? 
In the documentation the opposite is told! 

This is my network topology.

(net1) - COMMUN4(router+WINS+LMB) --|HUB|-- COMMUN2(router+LMB+DMB) - (net2)
   eth1(192.168.4.1)    eth0(ext.ip)    eth1(ext.ip2)     eth0(192.168.2.1)

Other segments also are connected to this hub. The hub passes broadcast 
packages.

About:
interfaces = eth0 192.168.4.1/16 (or /24),lo 127.0.0.1/8
interfaces = eth0 192.168.2.1/16 (or /24),lo 127.0.0.1/8

The samba does not listen to external network interfaces.
For security reasons, it to do it is impossible.

To this configuration servers can easily connect with each other and download 
files (through samba, I use it very often). 

I do not have any filtering programs and rules in iptables.

[2003/08/15 10:29:15, 0] nmbd/nmbd_browsesync.c:domain_master_node_status_fail
(262)
  domain_master_node_status_fail:
  Doing a node status request to the domain master browser
  for workgroup COMNET at IP 192.168.4.1 failed.
  Cannot sync browser lists.

Look. The server has successfully found DMB. In what a problem? 
I started to do experiments. Please, look on bug 310 - it is my results.
Comment 5 Gerald (Jerry) Carter 2004-01-14 20:42:38 UTC
This is a networking issue.  The WINS lookup for the DMB 
will go to 192.168.4.1 but will go out eth0 on the LMB so 
the packet will never reach the WINS server.
Comment 6 Gerald (Jerry) Carter 2005-02-07 07:57:27 UTC
originally reported against 3.0aph24.  Bugzilla spring cleaning.  
Removing old alpha versions.
Comment 7 Gerald (Jerry) Carter 2005-11-14 09:27:58 UTC
database cleanup