Bug 2937 - rm: autom4te*.cache: File name too long
rm: autom4te*.cache: File name too long
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.20
PPC Mac OS X
: P3 minor
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-01 11:29 UTC by Jason Mader
Modified: 2007-02-08 15:57 UTC (History)
0 users

See Also:


Attachments
Level 10 log file (238.71 KB, application/octet-stream)
2005-08-01 14:55 UTC, Jason Mader
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Mader 2005-08-01 11:29:37 UTC
autogen is run on OS X, the samba source directory is mounted via a Samba share.

aluminum% ./autogen.sh 
./autogen.sh: running script/mkversion.sh
./script/mkversion.sh: 'include/version.h' created for Samba("3.0.20rc1")
rm: autom4te*.cache: File name too long
./autogen.sh: running autoheader
./autogen.sh: running autoconf
Now run ./configure and then make.
Comment 1 Tim Potter 2005-08-01 12:32:10 UTC
I guess you are using the Mac OS X client to mount the share?  

Is it possible to get a level 10 debug log of what's happening on the Samba side
when you run autogen.sh?  It sounds like a long filename bug in the Samba server.
Comment 2 Jason Mader 2005-08-01 14:48:03 UTC
[2005/08/01 17:37:38, 10] lib/util.c:(1995)
  [000] 00 00 00 16 00 04 00 07  00 04 01 00 00 00 00 5C  ........ .......\
  [010] 00 6E 00 63 00 61 00 63  00 5C 00 6A 00 61 00 73  .n.c.a.c .\.j.a.s
  [020] 00 6F 00 6E 00 5C 00 70  00 6F 00 72 00 74 00 73  .o.n.\.p .o.r.t.s
  [030] 00 5C 00 73 00 61 00 6D  00 62 00 61 00 5C 00 73  .\.s.a.m .b.a.\.s
  [040] 00 61 00 6D 00 62 00 61  00 2D 00 33 00 2E 00 30  .a.m.b.a .-.3...0
  [050] 00 2E 00 32 00 30 00 72  00 63 00 31 00 5C 00 73  ...2.0.r .c.1.\.s
  [060] 00 6F 00 75 00 72 00 63  00 65 00 5C 00 61 00 75  .o.u.r.c .e.\.a.u
  [070] 00 74 00 6F 00 6D 00 34  00 74 00 65 00 2A 00 2E  .t.o.m.4 .t.e.*..
  [080] 00 63 00 61 00 63 00 68  00 65 00 00 00           .c.a.c.h .e...
[2005/08/01 17:37:38, 3] smbd/process.c:(886)
  switch message SMBtrans2 (pid 7119) conn 0x10361960
[2005/08/01 17:37:38, 4] smbd/uid.c:(194)
  change_to_user: Skipping user change - already user
[2005/08/01 17:37:38, 3] smbd/trans2.c:(1348)
  call_trans2findfirst: dirtype = 22, maxentries = 4, close_after_first=1, close_if_end = 2 
requires_resume_key = 4 level = 0x104, max_data_bytes = 16644
[2005/08/01 17:37:38, 5] smbd/filename.c:(108)
  unix_convert called on file "ncac/jason/ports/samba/samba-3.0.20rc1/source/autom4te*.cache"
[2005/08/01 17:37:38, 10] smbd/statcache.c:(210)
  stat_cache_lookup: lookup failed for name [NCAC/JASON/PORTS/SAMBA/SAMBA-3.0.20RC1/SOURCE/
AUTOM4TE*.CACHE]
[2005/08/01 17:37:38, 10] smbd/statcache.c:(243)
  stat_cache_lookup: lookup succeeded for name [NCAC/JASON/PORTS/SAMBA/SAMBA-3.0.20RC1/
SOURCE] -> [ncac/jason/ports/samba/samba-3.0.20rc1/source]
[2005/08/01 17:37:38, 5] smbd/filename.c:(175)
  unix_convert begin: name = ncac/jason/ports/samba/samba-3.0.20rc1/source/autom4te*.cache, 
dirpath = ncac/jason/ports/samba/samba-3.0.20rc1/source, start = autom4te*.
cache
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(276)
  is_mangled autom4te*.cache ?
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(215)
  is_mangled_component autom4te*.cache (len 15) ?
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(276)
  is_mangled autom4te*.cache ?
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(215)
  is_mangled_component autom4te*.cache (len 15) ?
[2005/08/01 17:37:38, 5] smbd/filename.c:(324)
  New file autom4te*.cache
[2005/08/01 17:37:38, 5] smbd/trans2.c:(1404)
  dir=ncac/jason/ports/samba/samba-3.0.20rc1/source, mask = autom4te*.cache
[2005/08/01 17:37:38, 5] smbd/dir.c:(371)
  dptr_create dir=ncac/jason/ports/samba/samba-3.0.20rc1/source
[2005/08/01 17:37:38, 3] smbd/dir.c:(475)
  creating new dirptr 256 for path ncac/jason/ports/samba/samba-3.0.20rc1/source, expect_close = 1
[2005/08/01 17:37:38, 4] smbd/trans2.c:(1431)
  dptr_num is 256, wcard = autom4te*.cache, attr = 22
[2005/08/01 17:37:38, 8] smbd/trans2.c:(1436)
  dirpath=<ncac/jason/ports/samba/samba-3.0.20rc1/source> dontdescend=<>
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 4
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 6
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 9
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 11
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 14
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: smbwrapper -> 477F2B1E -> SJU5ST~A (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 17
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: rpc_client -> 3CD416B8 -> RGVLJU~G (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 20
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: rpcclient -> 4C132FCB -> RL3W3B~F (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 23
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 26
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 28
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 31
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 33
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 36
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 38
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 40
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 43
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: config.guess -> 1A6270A2 -> C7BJPU~Q (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 46
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 49
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 51
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 53
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 56
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 59
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 62
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: pam_smbpass -> 0939B27D -> P2K5E2~L (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 64
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 66
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 68
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 71
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 74
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 77
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: rpc_server -> 11A64654 -> R4WANO~4 (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 80
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 83
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 85
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 87
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 89
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 92
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: .dmallocrc -> 5168C9DE -> _ML6AX~Q (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 95
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: rpc_parse -> 53F0615E -> RNAFYA~M (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 97
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 100
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 103
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 106
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: codepages -> 29B8C676 -> CBKQWD~Y (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 109
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: configure.in -> 4946D19B -> CKBXU3~F.IN (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 112
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 115
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 117
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 120
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: smbadduser.in -> 2473BA9B -> SA43XY~3.IN (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 122
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 125
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 128
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: dynconfig.c -> 608D2C04 -> DQSFBI~C.C (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 131
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: change-log -> 3D549BC8 -> CH0M2T~K (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 134
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 137
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 140
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 144
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: configure.developer -> 781764F7 -> CXBK4X~J (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 147
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 150
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 153
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 156
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: install-sh -> 7A9291DE -> IY0CCF~2 (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 159
[2005/08/01 17:37:38, 10] smbd/mangle_hash2.c:(612)
  name_map: configure -> 4946D19B -> CKBXU3~F (cache=0)
[2005/08/01 17:37:38, 8] smbd/trans2.c:(868)
  get_lanman2_dir_entry:readdir on dirptr 0x10367710 now at offset 159
[2005/08/01 17:37:38, 5] smbd/trans2.c:(1482)
  call_trans2findfirst - (2) closing dptr_num 256
[2005/08/01 17:37:38, 4] smbd/dir.c:(220)
  closing dptr key 256
[2005/08/01 17:37:38, 3] smbd/error.c:(125)
  error packet at smbd/trans2.c(1498) cmd=50 (SMBtrans2) NT_STATUS_NO_SUCH_FILE
Comment 3 Jason Mader 2005-08-01 14:55:26 UTC
Created attachment 1349 [details]
Level 10 log file

Samba 3.0.13
Comment 4 Tim Potter 2005-08-02 09:14:54 UTC
Nice work.  I think perhaps the wrong error code is being returned for the
trans2_findfirst call you have pasted into the log.  I don't know this code very
well though.
Comment 5 Jason Mader 2006-06-29 10:39:49 UTC
This is still around in 3.0.22.  I just tried Sharity 3.2 beta 2 on OS X as the client:

aluminum% ./autogen.sh 
./autogen.sh: running script/mkversion.sh
./script/mkversion.sh: 'include/version.h' created for Samba("3.0.24pre1-SVN-build-16665")
./autogen.sh: running autoheader
autom4te: cannot lock autom4te.cache/requests with mode 2 (perhaps you are running make -j on a lame NFS client?): Operation not supported
autoheader: /usr/bin/autom4te failed with exit status: 1
Comment 6 James Peach 2007-02-08 15:57:37 UTC
Unable to reproduce with a Leopard client and server.