Bug 2928 - Deadlock between smbd and winbindd
Deadlock between smbd and winbindd
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.20
Sparc Solaris
: P3 regression
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-29 05:36 UTC by Olaf Imig
Modified: 2005-08-24 10:18 UTC (History)
0 users

See Also:


Attachments
log.smbd (76.35 KB, text/plain)
2005-07-29 05:37 UTC, Olaf Imig
no flags Details
log.wb (2.60 KB, text/plain)
2005-07-29 05:38 UTC, Olaf Imig
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf Imig 2005-07-29 05:36:36 UTC
Testing the 3.0.20pre, I found the following serious bug. My sambaserver is a
Domainmember (no trusted domain) on a Solaris/Sparc Platform. I found this bug
for the first time in the 3.0.20pre2-release, the 3.0.15pre2 works fine.
The BUG seems to be similar to bug 1008. When I start winbindd, it gave up to
get a lock on a file, which is already locked by smbd. After that winbindd
crash. I cant't connect to the sambaserver. Without winbindd samba works.

Here the important locations in the logfile:

*** (smbd) ***
[2005/07/29 14:07:39, 8] lib/util.c:(1815)
  fcntl_lock 16 34 0 1 2
[2005/07/29 14:07:39, 8] lib/util.c:(1850)
  fcntl_lock: Lock call successful

*** (winbindd) ***
[2005/07/29 14:07:39, 8] lib/util.c:(1815)
  fcntl_lock 16 34 0 1 1
[2005/07/29 14:07:39, 3] lib/util.c:(1826)
  fcntl_lock: fcntl lock gave errno 11 (Resource temporarily unavailable)
[2005/07/29 14:07:39, 3] lib/util.c:(1845)
  fcntl_lock: lock failed at offset 0 count 1 op 34 type 1 (Resource temporarily
 unavailable)
Comment 1 Olaf Imig 2005-07-29 05:37:27 UTC
Created attachment 1341 [details]
log.smbd
Comment 2 Olaf Imig 2005-07-29 05:38:09 UTC
Created attachment 1342 [details]
log.wb
Comment 3 Volker Lendecke 2005-07-29 07:14:50 UTC
Two things: Apparently you are facing a segfault in winbind that has been fixed
for 3.0.20rc1 which was just released, so please retry that.

The log.smbd you sent does not really show anything relevant. It appears that
you have 'log file = ...log.%m' or something else with %m in your smb.conf. If
you still see the bug with 3.0.20rc1, could you please remove this line or
alternatively send in a tar with all smbd logfiles?

Thanks,

Volker
Comment 4 Olaf Imig 2005-08-01 07:08:01 UTC
(In reply to comment #3)
> Two things: Apparently you are facing a segfault in winbind that has been fixed
> for 3.0.20rc1 which was just released, so please retry that.
> 
> The log.smbd you sent does not really show anything relevant. It appears that
> you have 'log file = ...log.%m' or something else with %m in your smb.conf. If
> you still see the bug with 3.0.20rc1, could you please remove this line or
> alternatively send in a tar with all smbd logfiles?
> 
> Thanks,
> 
> Volker

Hallo,

I tested 3.0.20rc1 and all seems to be work fine. 

Thanks, Olaf 
Comment 5 Gerald (Jerry) Carter 2005-08-15 11:42:18 UTC
closing.
Comment 6 Gerald (Jerry) Carter 2005-08-24 10:18:07 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.