Bug 2917 - UsrMgr tools works unexpected
UsrMgr tools works unexpected
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.14a
x86 Linux
: P3 normal
: none
Assigned To: Jim McDonough
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-25 09:38 UTC by Paul
Modified: 2005-09-07 07:31 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul 2005-07-25 09:38:35 UTC
Adding users to sambda domain using UsrMgr.exe doesn't works as expected.

Example 1:
a) run UsrMgr.exe
b) User -> New User
c) Login Name: test_user
d) Add
receive: Access denied
refresh
result: user added w/o password set

passdb backend = ldapsam:ldap://localhost
add user script = /root/samba/useradd.sh "%u"

/root/samba/useradd.sh:
  useradd -s /bin/false -m -d /home/$1 $1
  smbldap-useradd -a $1 -H [U]

------------------------------------------------------------
Example 2:
a) run UsrMgr.exe
b) User -> Delete -> Ok
c) Yes
stuck for a while
result: user deleted

Logs output:
[2005/07/25 19:31:47, 0] lib/smbldap.c:smbldap_open(882)
  smbldap_open: cannot access LDAP when not root..
...
[2005/07/25 19:32:33, 0] passdb/pdb_ldap.c:ldapsam_search_one_group(1971)
  ldapsam_search_one_group: Problem during the LDAP search: LDAP error:  (Timed out)
Comment 1 Gerald (Jerry) Carter 2005-08-30 05:36:08 UTC
user manage support needs an overhaul and some solid testing.  
This is on the plater for 3.0.21
Comment 2 Gerald (Jerry) Carter 2005-09-01 12:38:34 UTC
jmcd wants these.  So here you go.
Comment 3 Gerald (Jerry) Carter 2005-09-01 12:39:03 UTC
reopen
Comment 4 Jim McDonough 2005-09-06 13:55:52 UTC
Can you please give more details on this?  I can add/delete users in ldap with
no problem.  I'm assuming this has something to do with the user you're using to
run usrmgr.

Please attach a level5 log and smb.conf file if you can still recreate this (and
reopen the bug).
Comment 5 Paul 2005-09-06 21:21:10 UTC
(In reply to comment #4)
> Can you please give more details on this?  I can add/delete users in ldap with
> no problem.  I'm assuming this has something to do with the user you're using to
> run usrmgr.
> 
> Please attach a level5 log and smb.conf file if you can still recreate this (and
> reopen the bug).

The problem is only with UsrMgr tools
Comment 6 Jim McDonough 2005-09-07 05:25:41 UTC
Paul, I'm using usrmgr.exe with no problems, doing the exact add and delete you
mention.  Can you please post the debug log, smb.conf (and probably a tcpdump or
ethereal network trace) I requested?
Comment 7 Paul 2005-09-07 06:54:00 UTC
(In reply to comment #6)
> Paul, I'm using usrmgr.exe with no problems, doing the exact add and delete you
> mention.  Can you please post the debug log, smb.conf (and probably a tcpdump or
> ethereal network trace) I requested?

Unfortunately I can't reproduce this problem at the moment because i switched
jobs, but I'll try to ask a guy left at old place, and reply to you later.

PS: If I remember right - when i ran Samba with default password backend UsrMgr
tool worked ok. Still, I think this interoperation issue should be investigated
more deeply.
Comment 8 Jim McDonough 2005-09-07 07:31:13 UTC
This is exactly what I've been doing...running samba with ldap backend, using
usrmgr from both winnt and win2k.  Sorry, but without more information on
recreating it (and verification of your setup) there's not much I can do.  There
are other parts of usrmgr that aren't working, but adding/deleting users is
working.  Chances are this piece was a configuration issue.  Please reopen this
only if you can give me debugging data, or get this former coworker to post it.  

Also, in the future, please try to make sure you post more information such as
smb.conf and maybe a low level debug log to any bugzilla so we can get a better
start and maybe even recreate problems without having to get more information. 
Thanks.