Bug 2888 - In certain scenarios cannot delete file from Windows share
In certain scenarios cannot delete file from Windows share
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.9
All Solaris
: P3 regression
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-18 13:39 UTC by Loren Erickson
Modified: 2005-09-28 08:08 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Loren Erickson 2005-07-18 13:39:06 UTC
Samba release 3.0.14a exibitted the problem.  Rolling back to Samba 3.0.10
fixed the problem.

The problem is that for a network share with say 4,000 files in it, some
Windows computers can delete files in this share and some cannot.

It seems that slower computers can delete files from this good size network
share but faster newer computers cannot (get access denied).

If we copy some of the files in the good size share into a smaller 
share we can delete files just fine on both fast and slow computers.

Also on this good size network share we can write/read files just fine,
it was only deleting files that was a problem.

Hope this helps to find this problem in the next release if it is not
fixed already.

Loren Erickson
Software Engineer
Brown Printing Company
Comment 1 Jeremy Allison 2005-07-21 16:26:59 UTC
This is something I believe we've fixed in the 3.0.20 pre releases. Could you
please test these out to confirm.
Thanks,
Jeremy.
Comment 2 Gerald (Jerry) Carter 2005-09-28 08:08:59 UTC
no feedback.  Closing.