Bug 2877 - Cannot build Samba on Solaris
Cannot build Samba on Solaris
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
Sparc Solaris
: P3 regression
: none
Assigned To: Tim Potter
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-07-14 15:01 UTC by ClemensCap
Modified: 2005-07-15 15:18 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description ClemensCap 2005-07-14 15:01:35 UTC
Build proces aborts when making dynconfig.c claiming a parse error in
include/proto.h at line 600 at LDAP_CONST

Probably a missing include file.

Did not find work around, presently stuck without samba on my machine. :-(

Would be grateful for a hint to cap@informatik.uni-rostock.de
Comment 1 Tim Potter 2005-07-14 16:38:55 UTC
What version of LDAP are you using to compile with?  I believe Samba 3 only
compiles with the OpenLDAP library at the moment.
Comment 2 Gerald (Jerry) Carter 2005-07-15 15:18:42 UTC
yup.  we require the openldap client libs.  We cannot 
use the solaris headers at this time.