Bug 2876 - Samba/Winbind bug
Summary: Samba/Winbind bug
Status: RESOLVED WORKSFORME
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: winbind (show other bugs)
Version: 3.0.14a
Hardware: x86 Linux
: P3 major
Target Milestone: none
Assignee: Samba Bugzilla Account
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-14 05:55 UTC by tornado
Modified: 2005-09-28 08:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tornado 2005-07-14 05:55:45 UTC
Hi,

Here is the information on the installed versions:

Samba:

ldapsmb-1.31-0.46
libsmbclient-3.0.14a-0.4
libsmbclient-devel-3.0.14a-0.4
samba-3.0.14a-0.4
samba-client-3.0.14a-0.4
samba-pdb-3.0.14a-0.4
samba-vscan-0.3.6-0.5
samba-winbind-3.0.14a-0.4

Kerberos:

heimdal-0.6.1rc3-55.3
pam_krb5-1.3-201.1

I am using samba to autheticate against the Windows 2003 AD domain. I can very well 
connect to the domain, get the kerberos ticket. I can also browse the username
and groups on 

the AD. The problem is show in the winbind logs. When intially start the winbind
and smb 

daemon i can connect to the samba shares with the AD username and password from
windows xp. But after sometime it does not authenticate at all nor the AD users
nor the local ones. Here is the log show by the winbind:


[2005/07/14 18:15:31, 0] libsmb/clientgen.c:cli_receive_smb(121)
  SMB Signature verification failed on incoming packet!
[2005/07/14 18:15:31, 0] libsmb/smb_signing.c:signing_good(232)
  signing_good: BAD SIG: seq 1
[2005/07/14 18:15:31, 0] libsmb/clientgen.c:cli_receive_smb(121)
  SMB Signature verification failed on incoming packet!
[2005/07/14 18:15:31, 0] libsmb/smb_signing.c:signing_good(232)
  signing_good: BAD SIG: seq 1
[2005/07/14 18:15:31, 0] libsmb/clientgen.c:cli_receive_smb(121)
  SMB Signature verification failed on incoming packet!
[2005/07/14 18:20:31, 0] libsmb/smb_signing.c:signing_good(232)
  signing_good: BAD SIG: seq 1
[2005/07/14 18:20:31, 0] libsmb/clientgen.c:cli_receive_smb(121)
  SMB Signature verification failed on incoming packet!
[2005/07/14 18:20:31, 0] libsmb/smb_signing.c:signing_good(232)
  signing_good: BAD SIG: seq 1
[2005/07/14 18:20:31, 0] libsmb/clientgen.c:cli_receive_smb(121)
  SMB Signature verification failed on incoming packet!
[2005/07/14 18:20:31, 0] libsmb/smb_signing.c:signing_good(232)
  signing_good: BAD SIG: seq 1
[2005/07/14 18:20:31, 0] libsmb/clientgen.c:cli_receive_smb(121)
  SMB Signature verification failed on incoming packet!


Any solutions on this one ?
I am really frustrated out of this one. 

Thanks in advance.
Comment 1 Gerald (Jerry) Carter 2005-08-29 14:29:28 UTC
There's not enough information here to move forward.
I would recommend ensuring that you are using the 
rc4hmac enc type and not DES keys in krb5.conf on the 
client.  There is no known outstanding bug in the 
smb signing code.
Comment 2 Gerald (Jerry) Carter 2005-09-28 08:10:42 UTC
closing.  no feedback from reporter.