Bug 2866 - Samba don't show version
Samba don't show version
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
x86 Windows 2000
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-07-08 07:29 UTC by Marc DENTEL
Modified: 2005-08-24 10:24 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Marc DENTEL 2005-07-08 07:29:16 UTC
I've compiled the samba-server-3.0.14a successfully.
But when typing : # smbd -V
SAMBA doesn't show me his version.
So when launching WEBMIN samba module, it tells me : "Unable to detect SAMBA 
version, please look at your configuration!"

What can I do ?
Comment 1 Gerald (Jerry) Carter 2005-07-08 08:27:44 UTC
Are you sure you are running the newly built smbd ?
Comment 2 Lars Müller 2005-07-08 08:54:08 UTC
I can't reproduce the bug report on a current Linux system.

I've tried just some minutes ago a simple

tar xfj samba-3.0.14a.tar.bz2
cd samba3.0.14a/source
make proto
make bin/smbd
./bin/smbd -V
Version 3.0.14a
Comment 3 Gerald (Jerry) Carter 2005-07-15 15:29:21 UTC
can't reproduce
Comment 4 Marc DENTEL 2005-07-18 09:50:13 UTC
Excuse me, I was wrong. I didn't use a compiled version of SAMBA but RPMS for 
Mandrake found on "rpm.pbone.net".
It seems that I have to use sources version instead of RPM.

Thanks for help.
Comment 5 Tim Potter 2005-07-18 17:37:58 UTC
Still fixed.
Comment 6 Gerald (Jerry) Carter 2005-08-24 10:24:18 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.