Bug 2865 - ACLs not completly inherited to files in directory/subdirectory
ACLs not completly inherited to files in directory/subdirectory
Status: RESOLVED DUPLICATE of bug 2864
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.14a
Sparc Solaris
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-08 05:16 UTC by Thomas Müller
Modified: 2005-07-08 05:29 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Müller 2005-07-08 05:16:02 UTC
I have a folder with permissions 775 and set additional ACL for 2 other groups
with rwx. New files in this folder or subfolder should have the ACL from the
parent folder and permissions 775. With inherit acl=yes only new subfolders are
created with the ACL from the parent folder. With inherit permissions=yes a new
file only inherits r/w bits from the parent folder, the execute bit is not
inherited since this parameter overrides i.e. force create mode. This leads to
access problems for the users. So it is not possible to create new files with
the permissions 775 and the ACL from the parent folder.
Is it possible to implement this function in a future Release (3.0.21?)

Regards
Thomas Müller
Comment 1 Björn Jacke 2005-07-08 05:29:42 UTC

*** This bug has been marked as a duplicate of 2864 ***