Bug 2853 - Showing jobs with cups backend doesn't work
Showing jobs with cups backend doesn't work
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.14a
All Linux
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-06 10:13 UTC by Ximo
Modified: 2005-08-24 10:17 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ximo 2005-07-06 10:13:36 UTC
I can see this error every time a windows client tries to see the jobs for
any of the printers on the print server:
(log.smbd)

[2005/07/05 16:22:12, 0] printing/print_cups.c:cups_queue_get(790)
  Unable to get jobs for ipp://localhost/printers/oce_ -
client-error-not-found

The result is that clients can't view (cancel or pause) any of the jobs
on the queue.

I also can see this error on the cups error log:
(error_log)

E [05/Jul/2005:16:22:12 +0200] get_jobs: resource name '/printers/oce_'
no good!


Of course, printer oce_ on localhost doesn't exist. Printer is named
oce$. I guess samba is translating "$" to "_".
On the other hand, users can print without problem. It looks like the
problem appears only showing the jobs.
Comment 1 Gerald (Jerry) Carter 2005-07-15 09:59:53 UTC
The problem is the call to pstring_sub() in print_queue_update().
string_sub() replaces all '$' characters with '_'.
Comment 2 Gerald (Jerry) Carter 2005-07-15 10:39:26 UTC
Fixed in the 3.0 svn tree.  YOu can grab the patch from:
http://websvn.samba.org/cgi-bin/viewcvs.cgi?rev=8506&view=rev
Comment 3 Gerald (Jerry) Carter 2005-08-24 10:17:56 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.