Bug 2842 - NET ADS JOIN Command Fails -> Glibc Change?
NET ADS JOIN Command Fails -> Glibc Change?
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: net utility
3.0.14a
x86 Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-30 13:37 UTC by Garth DAttilo
Modified: 2005-08-30 05:47 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Garth DAttilo 2005-06-30 13:37:10 UTC
Using Fedora Core 4, the net ads add command fails with the following error
(followed by the usual trace):
   *** glibc detected *** net: free(): invalid pointer: 0x004d27f0
======= Backtrace: =========
/lib/libc.so.6[0x2b7424]
/lib/libc.so.6(__libc_free+0x77)[0x2b795f]
/lib/libcom_err.so.2(remove_error_table+0x4b)[0x128abb]
/usr/lib/libkrb5.so.3[0x470823]
/usr/lib/libkrb5.so.3[0x4705c7]
/usr/lib/libkrb5.so.3[0x4c13ba]
/lib/ld-linux.so.2[0xaf2058]
/lib/libc.so.6(exit+0xc5)[0x27ec69]
/lib/libc.so.6(__libc_start_main+0xce)[0x268dee]
net[0x8e70f1]
----------------------------------------------------------------------------
It looks like the repsonse to invalid 'free()' calls has changed. 
   
   You can get around this by manually setting MALLOC_CHECK to either 0 (ignore)
or 1 (report and continue) but that's not at all obvious at the outset. :-)

Thanks,
Garth D'Attilo
NCAR/ACD Systems Administrator
Comment 1 Garth DAttilo 2005-06-30 13:46:14 UTC
Hmmm... Looks like that should be "net ads join"...
-Garth
Comment 2 Gerald (Jerry) Carter 2005-07-15 15:36:04 UTC
any chance of getting a backtrace with debug symbols 
(compile with --enable-debug)?  
Comment 3 Garth DAttilo 2005-07-25 12:59:41 UTC
Version 3.0.20pre2 compiled with --enable-debug. Debug level set to 10.
Everything seems to progress normally until this point.
Please let me know if you want the entire log file or if I have misunderstood
what you are asking for.

Thanks in advance,
Garth

-----------------------------------------------------------------------

[2005/07/21 17:54:28, 2] utils/net.c:main(897)
  return code = 0
*** glibc detected *** /usr/bin/net: free(): invalid pointer: 0x001c8db0 ***
======= Backtrace: =========
/lib/libc.so.6[0x2c7424]
/lib/libc.so.6(__libc_free+0x77)[0x2c795f]
/lib/libcom_err.so.2(remove_error_table+0x4b)[0x1c9abb]
/usr/lib/libkrb5.so.3[0x1668c4]
/usr/lib/libkrb5.so.3[0x1665c7]
/usr/lib/libkrb5.so.3[0x1b79da]
/lib/ld-linux.so.2[0x7f7058]
/lib/libc.so.6(exit+0xc5)[0x28ec69]
/lib/libc.so.6(__libc_start_main+0xce)[0x278dee]
/usr/bin/net[0xa270f1]
Comment 4 Gerald (Jerry) Carter 2005-07-25 13:02:51 UTC
Garth,

I reproduce the same issue locally.  This looks like a 
bug in the kerberos libs which I think redhat will have to 
handle with the MIT folks.  I've copied Jay Fenlason at redaht
on this bug.
Comment 5 Gerald (Jerry) Carter 2005-08-30 05:47:23 UTC
This is a bug in the e2fsprogs on FC4.  Confirmed by RH developers.
Not our bug.