Bug 2840 - Windows XP w/sp2 access denied after uploading client drivers
Windows XP w/sp2 access denied after uploading client drivers
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.14a
x86 Linux
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-29 23:05 UTC by Chris Anders
Modified: 2005-08-30 05:47 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Anders 2005-06-29 23:05:17 UTC
Not sure how to explain what i have found but basically i have installed samba 3.0.14a at four different 
sites and have experienced problems uploading printer client drivers from windows xp w/sp2. Yet with 
windows 2000 w/sp4 everything works fine.

The problem i have at the two windows xp sites is when i go to upload the client driver it shows the 
copy process and then at the end of the process it brings up an error dialog telling me that access is 
denied. 

Looking at  /var/log/messages every time i open the printer and fax folder on the samba server i get 
this message "couldn't find service ::{2227a280-3aea-1069-a2de-08002b30309d}" with "smbd/
nttrans.c:call_nt_transact_ioctl(2276)" on the next line.

I have made sure all permissions / config are the same to the working samba servers running 3.0.14a 
with windows 2000 clients and they all seem identical as each site are fresh linux installs.

I am running gentoo linux and have tried the gentoo ebuilds as well as manual configure / install

As a test i decided to install 3.0.10 where i found that windows xp could upload the drivers and the 
same error messages appeared in /var/log/messages about not finding the service yet “Added printer 
driver. Print driver name: Kyocera Mita FS-1010 (KPDL-2). Print driver OS: WIN2K. Administrator name: 
root.” was now showing up.  However when I reboot the server samba magically forgets that I have 
uploaded drivers  yet when I look in the print$ folder I can see the drivers have been uploaded…

Once again with windows 2000 w/sp4 these problems do not show, I have also tried installing the 
printer driver using the ip as appose to the netbios name ie \\0.0.0.0 vs \\name and the same problem 
occurs so this makes no difference.

As I don’t believe I am the only one running windows xp using printing with samba perhaps there is 
something I am missing? I find it strange that i can reproduce this at any site running windows xp so 
maybe it is a config issue on my side? or something that has been overlooked and all the devs only run 
windows 2000...
Comment 1 Gerald (Jerry) Carter 2005-07-04 09:10:12 UTC
Chris,  Everything should be working fine with XP clients.

Samba stores printer driver information in 2 places.
(a) The meta information is stored in $(lockdir)/nt*tdb files 
    Are these getting deleting on reboots?
(b) The driver files are stored in [print$]

To track down the access denied messages, run a level 10 
debug log and grep for WERR_ACCESS_DENIED or NT_STATUS_ACCESS_DENIED
and look at the currounding text.
Comment 2 Gerald (Jerry) Carter 2005-07-15 09:38:33 UTC
mail from Chris on Jul 5, 2005:

> I find it odd that identical setups work fine with the win2k clients  vs
> the winxp with nothing different in setup. When im next on site i  will
> go through what you have suggested to get you more info. However  i can
> replicate the problem that in version 3.0.10 it will add the  printer
> driver(yet dissapear on reboot),  in 3.0.14a it will show the  copying
> process and at the end of copying it will show a permission  error.
> looking where i have my print$ share set i see no files being  uploaded
> under 3.0.14a yet 3.0.10 i can see the drivers uploaded.
Comment 3 Gerald (Jerry) Carter 2005-07-15 11:25:53 UTC
Chris,  I'm in a holding pattern on this one until you can supply 
some level 10 smbd debug logs.  Thanks.
Comment 4 Chris Anders 2005-07-16 05:35:32 UTC
I have been away however I will have some logs for you in the next few days. I am also building another 
server for a windowsXP network so I shall see if the problem occurs again.


(In reply to comment #3)
> Chris,  I'm in a holding pattern on this one until you can supply 
> some level 10 smbd debug logs.  Thanks.

Comment 5 Gerald (Jerry) Carter 2005-08-30 05:47:01 UTC
no feedback in over a month and cannot reproduce.  Closing.