Bug 2830 - ntlm_auth helper will not authenticate users w/o DOMAIN\USER
ntlm_auth helper will not authenticate users w/o DOMAIN\USER
Product: Samba 3.0
Classification: Unclassified
Component: ntlm_auth tool
x86 Linux
: P3 minor
: none
Assigned To: Andrew Bartlett
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-06-27 21:26 UTC by Jonathan Cunningham
Modified: 2010-02-15 15:24 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Cunningham 2005-06-27 21:26:03 UTC
Really starting to drive me up a wall.

Users logging on via Netscape or machines not in domain (i.e. Win98 in 
workgroup mode) MUST supply their domain as well as username.

Can this be done with some simple switch I'm missing to allow a "default 
lookup domain"?

YES, I am using "winbind use default domain = yes" in smb.conf :: no change
AND, I tried "--domain MYDOMAINNAME" switch in my squid.conf :: no change

I've looked up and down the internet for weeks on end, tried every 
configuration I can think of without downgrading back to Samba 2.x to use the 
old wb_ntlmauth helpers.
Comment 1 Kai Blin 2008-04-28 09:21:52 UTC
Is this still an issue in current Samba 3?
Comment 2 Kai Blin 2010-02-15 15:24:42 UTC
Closing as invalid due to inactivity. Please reopen if this still is an issue.
Comment 3 Kai Blin 2010-02-15 15:24:57 UTC
and closing