Bug 2813 - Cannot rename files with read-only attribute (Access denied)
Cannot rename files with read-only attribute (Access denied)
Status: RESOLVED DUPLICATE of bug 3035
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.14a
x86 Windows 2000
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-21 18:29 UTC by Jordan Russell
Modified: 2005-10-07 07:58 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jordan Russell 2005-06-21 18:29:36 UTC
With Samba 3.0.14a, an "access denied" error is returned if I try to rename a
file that has the read-only attribute set (i.e. no owner "w" permission).

This behavior is a regression from previous versions of Samba (e.g. 3.0.10) and
inconsistent with Windows (which allows read-only files to be renamed).

To reproduce:

1. On Windows (2000), map Y: to a Samba 3.0.14a share.

2. Open up Command Prompt and execute the following commands:

Y:\>echo test > a

Y:\>attrib +r a

Y:\>attrib a
A    R     Y:\a

Y:\>ren a b
Access is denied.


Notice that the "ren" command fails with an "Access is denied" error.

If I downgrade to 3.0.10 and execute the same commands, there is no error; the
file is successfully renamed.
Comment 1 Gerald (Jerry) Carter 2005-10-07 07:58:30 UTC

*** This bug has been marked as a duplicate of 3035 ***