Bug 280 - idmap_ldap does not initialize sambaNext[User|Group]Rid in the LDAP directory
idmap_ldap does not initialize sambaNext[User|Group]Rid in the LDAP directory
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.0preX
Other other
: P1 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-07 22:13 UTC by Gerald (Jerry) Carter
Modified: 2005-08-24 10:27 UTC (History)
0 users

See Also:


Attachments
remove allocated rid fields in ldap_idmap_state struct (1.81 KB, application/octet-stream)
2003-08-07 22:15 UTC, Gerald (Jerry) Carter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald (Jerry) Carter 2003-08-07 22:13:41 UTC
and we don't track the high water mark for allocated RID's :-(
Comment 1 Gerald (Jerry) Carter 2003-08-07 22:14:07 UTC
can ship without this working.
Comment 2 Gerald (Jerry) Carter 2003-08-07 22:15:24 UTC
Created attachment 64 [details]
remove allocated rid fields in ldap_idmap_state struct

i'm not ready to check this in, but I don't want to look it 
or forget about it either.
Comment 3 Gerald (Jerry) Carter 2003-08-11 17:25:57 UTC
added code to ad_new_domain_info() to add the 
sambaNextUserRid and sambaNextGroupRid attributes 
to the domain information entry if the 'idmap uid'
and 'idmap gid' parameters are defined.
Comment 4 Gerald (Jerry) Carter 2005-02-07 08:41:34 UTC
originally reported against 3.0.0beta3.  CLeaning out 
non-production release versions.
Comment 5 Gerald (Jerry) Carter 2005-08-24 10:27:02 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.