Bug 2797 - passdb.tdb modification timestamp not updated
passdb.tdb modification timestamp not updated
Status: RESOLVED DUPLICATE of bug 3101
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
3.0.14a
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-14 03:33 UTC by Holger Schletz
Modified: 2005-09-29 07:58 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Holger Schletz 2005-06-14 03:33:37 UTC
I'm using Samba 3.0.14 with tdbsam backend. The modification timestamp of 
passdb.tdb does rarely get updated when any changes are made to the passdb (I 
guess this is only done when the file size grows, but I can't prove that).

I'm sure there are changes to the file: I created a copy and changed a password. 
Running diff on the two files showed a difference. However, the timestamp was 
untouched.

This is a severe problem with incremental backups: I recently restored a totally 
outdated version since the backup software never recognized the change :-(
Comment 1 Gerald (Jerry) Carter 2005-09-29 07:58:31 UTC

*** This bug has been marked as a duplicate of 3101 ***