Bug 2789 - SMBD often hanging in read() at writing/modifiing files
SMBD often hanging in read() at writing/modifiing files
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.14a
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-10 16:58 UTC by Alfred Schweder
Modified: 2006-04-08 22:59 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alfred Schweder 2005-06-10 16:58:03 UTC
I'm using samba/stable uptodate 3.0.14a-3, samba-common/stable uptodate
3.0.14a-3 on a Debian server with kernel 2.6.11.6 with encryption and so on.
The server serve some shares for a couple of XP-SP2 Clients. This is working
very well till I change the ethernet card on the server and my client from
fastethernet to gigabit.

Browesing and reading and copying files (up to 5GB) are working still very
fine an now with sigificant more performance, BUT now the SMBD is hanging
often when I copy a directory to the server. Also modifing a file (~100K)
let the SMBD often hang. The problem is reproducible for me in a few minutes. 

I checked the network configuration more than once. Ping, ssh and other
services are working well at the same time. There are no problems working
on these files at command line. Different disk an so on make no changes
and the filesystem is clean. Also playing with the smb configuration
dosen't solve the problem but can reduce the time the XP client is hanging.

After I tried sometimes to copy a directory I have a bunch of hanging SMBDs. 
strace -p show that all the hanging SMBD are in a read() system call. At the
moment the SMBD stops working, a file is just created with the right size, but
it's still filled with 0. The XP system state after a while that it has lost
the connection to the server.

Email, if you have some questions ....
I can also activate some debug and test a special smbd on request.
Comment 1 Gerald (Jerry) Carter 2006-04-08 22:59:51 UTC
Please retest against a current release and reopen if the issue still exists.