Bug 2770 - Passwords with space cannot sync with unix
Passwords with space cannot sync with unix
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.14a
x86 FreeBSD
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-03 19:05 UTC by João Carlos Mendes Luis
Modified: 2006-01-14 12:51 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description João Carlos Mendes Luis 2005-06-03 19:05:59 UTC
If the user password has a space among its characters, the unix password sync
command does not work.  I suspect that the %n is being expanded BEFORE splitting
calling the chat sequence into parts.

To help, here's some output from the log file, in log level = 100 and passwd
chat debug = yes.  The test password is "teste 1".


  expect: expected [*new*password*] received [Enter new password:] match yes
[2005/06/03 22:19:17, 10, pid=90672, effective(0, 10000), real(0, 0)] smbd/chgpa
sswd.c:expect(286)
  expect: returning True
[2005/06/03 22:19:17, 100, pid=90672, effective(0, 10000), real(0, 0)] smbd/chgp
asswd.c:expect(238)
  expect: sending [teste]
[2005/06/03 22:19:19, 10, pid=90672, effective(0, 10000), real(0, 0)] lib/util_s
ock.c:read_socket_with_timeout(305)
  read_socket_with_timeout: timeout read. select timed out.
[2005/06/03 22:19:19, 100, pid=90672, effective(0, 10000), real(0, 0)] smbd/chgp
asswd.c:expect(275)
  expect: expected [1
  *new*password*] received [] match no
[2005/06/03 22:19:19, 2, pid=90672, effective(0, 10000), real(0, 0)] smbd/chgpas
swd.c:expect(281)
  expect: Unknown error: 0
[2005/06/03 22:19:19, 3, pid=90672, effective(0, 10000), real(0, 0)] smbd/chgpas
swd.c:talktochild(312)
Comment 1 William Jojo 2006-01-14 10:59:13 UTC
This is not a bug. Place double quotes around the %n's in the passwd chat. This worked for me on my AIX box.

Cheers,

Bill
Comment 2 Gerald (Jerry) Carter 2006-01-14 12:51:22 UTC
Bill says no bug.  Closing.