Bug 2757 - win2000 and winxp crash just openning file search if it's on domain
win2000 and winxp crash just openning file search if it's on domain
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.14a
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-31 12:48 UTC by Alejandro Mery
Modified: 2005-09-27 13:52 UTC (History)
0 users

See Also:


Attachments
tcpdump during search crash (5.44 KB, application/octet-stream)
2005-05-31 12:51 UTC, Alejandro Mery
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alejandro Mery 2005-05-31 12:48:32 UTC
On every win2000 and winxp i join the domain (.14a as PDC-LDAP) just openning
the file search window is enough to make explorer crash.

i get lot of no-sense NT_STATUS_OBJECT_NAME_NOT_FOUND errors on %m.log
Comment 1 Alejandro Mery 2005-05-31 12:51:48 UTC
Created attachment 1253 [details]
tcpdump during search crash
Comment 2 Alejandro Mery 2005-06-03 18:41:18 UTC
> i get lot of no-sense NT_STATUS_OBJECT_NAME_NOT_FOUND errors on %m.log

this is a sample... files requests have never been and will never be part of
profile or at the server.

[2005/06/03 18:50:32, 4] smbd/uid.c:change_to_user(194)
  change_to_user: Skipping user change - already user
[2005/06/03 18:50:32, 3] smbd/trans2.c:call_trans2qfilepathinfo(2418)
  call_trans2qfilepathinfo: TRANSACT2_QPATHINFO: level = 1004
[2005/06/03 18:50:32, 5] smbd/filename.c:unix_convert(108)
  unix_convert called on file "PSAPI.DLL"
[2005/06/03 18:50:32, 5] smbd/filename.c:unix_convert(175)
  unix_convert begin: name = PSAPI.DLL, dirpath = , start = PSAPI.DLL
[2005/06/03 18:50:32, 5] smbd/filename.c:unix_convert(324)
  New file PSAPI.DLL
[2005/06/03 18:50:32, 3] smbd/trans2.c:call_trans2qfilepathinfo(2443)
  call_trans2qfilepathinfo: SMB_VFS_STAT of PSAPI.DLL failed (No such file or
directory)
[2005/06/03 18:50:32, 3] smbd/error.c:error_packet(105)
  error string = No such file or directory
[2005/06/03 18:50:32, 3] smbd/error.c:error_packet(129)
  error packet at smbd/trans2.c(2197) cmd=50 (SMBtrans2)
NT_STATUS_OBJECT_NAME_NOT_FOUND
[2005/06/03 18:50:32, 5] lib/util.c:show_msg(464)
[2005/06/03 18:50:32, 5] lib/util.c:show_msg(474)
  size=35
  smb_com=0x32
  smb_rcls=52
  smb_reh=0
  smb_err=49152
  smb_flg=136
  smb_flg2=51265
  smb_tid=2
  smb_pid=1520
  smb_uid=105
  smb_mid=37888
  smt_wct=0
  smb_bcc=0

Comment 3 Gerald (Jerry) Carter 2005-09-27 13:52:20 UTC
The packets in the tcpdump are truncated.  Can you retest 
against 3.0.20 ?  There are no other reports of this
and I cannot reproduce it.  Please reopen if you can reproduce 
it against the current stable release.