Bug 2749 - all files have blank names
all files have blank names
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.14a
Other Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-28 21:31 UTC by Kevin Turner
Modified: 2005-09-29 08:46 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Turner 2005-05-28 21:31:45 UTC
Listing any directory in a share returns the correct number of entries, but all
the names are blank.  The log at -d10 say a bunch of this:

smbd/trans2.c:get_lanman2_dir_entry(869)

  get_lanman2_dir_entry:readdir on dirptr 0x10067320 now at offset 1

smbd/dosmode.c:dos_mode(283)

  dos_mode: usr/sbin/

smbd/dosmode.c:dos_mode_from_sbuf(151)

  dos_mode_from_sbuf returning d

smbd/dosmode.c:dos_mode(315)

  dos_mode returning d

smbd/trans2.c:get_lanman2_dir_entry(959)

  get_lanman2_dir_entry found usr/sbin/ fname=

smbd/trans2.c:get_lanman2_dir_entry(1043)

  get_lanman2_dir_entry: SMB_FIND_FILE_BOTH_DIRECTORY_INFO


and a packet capture has blanks or zeros for all fields such as file name lengh,
 allocation size, etc.  The only thing that's non-zero is "File Attributes:
0x00000010" (it's reporting them all as directories?)

samba 3.0.14a cross-compiled from x86 to mipsel against current uclibc with gcc
3.4.3, running under a vendor-supplied linux 2.4.21 kernel.
Comment 1 Kevin Turner 2005-05-28 21:33:02 UTC
but if I retrieve a file by name (smbclient '\\foo\tmp' -c 'get bar'), that does
work.
Comment 2 Derrell Lipman 2005-05-29 13:23:00 UTC
Would you please do a few things for us:

1. We have fixed some bugs related to directory listings fairly recently.  Would
you please verify that this bug still exist if you use the current code in SVN.

2. If the problem does still exist, please attach an ethereal or tcpdump packet
dump, in RAW, BINARY format, which will help us track down the problem.

3. What operating system (XP?  win2k?, etc.) and file system type (FAT?, NTFS?)
are in use on the computer on which you are trying to get the directory listing?

Thanks.
Comment 3 Kevin Turner 2005-05-30 12:19:34 UTC
Okay, this was a result of getting autoconf settings wrong for the cross-compile.
After mashing the config settings for a while, the problem is no longer.

I think a tip-off should have been all the "right shift count >= width of type"
errors during compile.  (When correctly configured those don't happen.)
Comment 4 Gerald (Jerry) Carter 2005-09-29 08:46:37 UTC
closing.