Bug 2728 - Can't execute lower or mixed-case files under DOS
Can't execute lower or mixed-case files under DOS
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.14a
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-19 16:08 UTC by Jim Louvau
Modified: 2005-09-07 07:15 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Louvau 2005-05-19 16:08:38 UTC
Sometime in the last 3 months or so (I don't use the functionality often) I lost
the ability to run executable files from (MS or PC)-DOS (IBM or MS LanMan
requesters) if the files are stored on the samba server in mixed or lower case.
The share is NOT case-sensitive, and in fact, I am able to list, move, rename,
copy, delete, etc any files using any mix of case. It's only when I try to run
an *.exe or *.com file that I get "Bad command or file name" error. If I rename
the file to all upper case, it executes just fine. FYI I don't have the same
problem executing from Windows 2000 or XP, so it appears to only affect LanMan
clients. Last time I ran code in DOS from a share was about 3 months ago and it
worked like it always has... just fine. The share / samba config haven't changed
in that long either, but I DO regularly update Samba. Host O/S is Debian Sarge
aka "Testing".
Comment 1 Gerald (Jerry) Carter 2005-09-07 07:15:29 UTC
This should be fixed in 3.0.20