Bug 2722 - corrupted filenames, created by initial gnome login
corrupted filenames, created by initial gnome login
Status: RESOLVED FIXED
Product: CifsVFS
Classification: Unclassified
Component: kernel fs
2.6
x86 Linux
: P3 major
: ---
Assigned To: Steve French
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-17 09:21 UTC by maarten de boer
Modified: 2005-08-31 09:25 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description maarten de boer 2005-05-17 09:21:57 UTC
Doing a gnome login with an empty home directory on a samba mounted directory,
several files are created with strange characters in the filenames in the end
(created by the initial gnome
login)

I cannot reproduce this creating the files by hand, and it certainly does not
happen when I do the login on a local directory, nor when I copy that local
directory to the samba directory.

I use cifs1.34a on top of a vanilla 2.6.11.9, and on both the client and
server side I use samba 3.0.14a

Some examples of the corrupted filenames (they should be called gconf.xml)

./.gconf/apps/panel/applets/clock_screen0/%gconf.xml汯
./.gconf/apps/panel/applets/clock_screen0/prefs/%gconf.xml†
./.gconf/apps/panel/applets/mixer_screen0/%gconf.xml汯
./.gconf/apps/panel/applets/notificationarea_screen0/%gconf.xml湥
./.gconf/apps/panel/applets/show_desktop_button_screen0/%gconf.xml潰
./.gconf/apps/panel/applets/trashapplet_screen0/%gconf.xml†
./.gconf/apps/panel/applets/window_list_screen0/%gconf.xml†
./.gconf/apps/panel/applets/window_list_screen0/prefs/%gconf.xml渠
./.gconf/apps/panel/applets/workspace_switcher_screen0/%gconf.xml敭
./.gconf/apps/panel/applets/workspace_switcher_screen0/prefs/%gconf.xml潷
./.gconf/apps/panel/objects/evolution_launcher_screen0/%gconf.xml敭
./.gconf/apps/panel/objects/firefox_launcher_screen0/%gconf.xml湥
etc
Comment 1 Steve French 2005-08-31 09:25:39 UTC
Fixed in cifs 1.35.  This fix should be in kernel 2.6.13.