Bug 2710 - "admin users" is not working together with "winbind use default domain = yes"
"admin users" is not working together with "winbind use default domain = yes"
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
x86 Solaris
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-05-13 03:44 UTC by Martynas Buozis
Modified: 2005-08-24 10:20 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Martynas Buozis 2005-05-13 03:44:08 UTC

I tried to make user Administrator to be root using "admin users" option in
smb.conf file. I found it not working with following options :

winbind use default domain = yes
admin users = administrator

I prefer to strip domain name and operate only with username on Solaris box
side, so I would like to use "default domain" for winbindd. But now I was forced
to switch to this setup :

winbind use default domain = no
admin users = DOMAIN\administrator

In this case user Administrator is really root. But this setup is not very good
because I prefer to use pure account names to login onto Solaris box using

I think this is a bug ?

Comment 1 Martynas Buozis 2005-05-13 03:51:21 UTC
Sorry. I also tried to use this form :

winbind use default domain = yes
admin users = DOMAIN\administrator

But it didn't work foer some reasons. Now I serach bugs DB and found this must
be correct form to enable "admin users". I tried this again with complete SAMBA
restart and it worked, so this is not a real bug. 

Thanks again.

Comment 2 Gerald (Jerry) Carter 2005-08-24 10:20:49 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.