Bug 2667 - Printer settings get lost when porting tdbs to another server
Printer settings get lost when porting tdbs to another server
Status: RESOLVED DUPLICATE of bug 3101
Product: Samba 3.0
Classification: Unclassified
Component: Printing
x86 Windows XP
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-04-28 03:17 UTC by Michael Arlt
Modified: 2005-09-27 12:10 UTC (History)
0 users

See Also:

ntdrivers (24.00 KB, application/octet-stream)
2005-06-20 01:16 UTC, Michael Arlt
no flags Details
ntforms (696 bytes, application/octet-stream)
2005-06-20 01:19 UTC, Michael Arlt
no flags Details
ntprinters (360.00 KB, application/octet-stream)
2005-06-20 01:20 UTC, Michael Arlt
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Arlt 2005-04-28 03:17:46 UTC
We had problems with our productive system with "samba" in our ads. So we 
installed a 3.0.13 Samba under Debian Sarge and configured 200 printers under 
Workgroup DEBIAN with netbios name "samba". Now we installed a new 3.0.14a 
Samba on Debian Sarge. After copying all tdbs and dlls to this server we 
joined our ads. All printers appear but the settings (memory, number of trays) 
are reseted to default. We exported the registries of both servers - only two 
things differ - no differents:

When we set the tray and memory options to the correct value and compare the 
registry again only:

- the value for "ChangeID" changes
- sometimes the key "objectGUID" appears

Nothing else changes. The part of the registry which is responsible for the 
tray-settings doesn't change.

Do you have an explanation for this behaviour?

Does there exist a possible solution to "activate" the correct printer 
Comment 1 Michael Arlt 2005-04-28 03:20:30 UTC
the netbios name of the old and new server is "samba"
Comment 2 Gerald (Jerry) Carter 2005-05-09 06:03:59 UTC
Michael,  couple of comments:

The changeID is a millisecond timestamp on the printer to 
help the client's maintain their print object local cache.
So that change is normal.  The GUID change is probably also
to be expected.

Now onto the meat of the report.  If you are using Windows 2000
clients or later, there is such as thing as a per user device 
mode which stores these printer settings (this is the printing 
preferences) as opposed to the global defaults (printing defaults).
Once you set a per user device mode on a client for your user 
profile, you will never again look at the global defaults for a 
printer.  So make sure there are nor per user device modes getting 
in the way of your testing.  Search support.microsoft.com for 
more information on device modes in general.

There is thing in the source code for 3.0.14a that would have 
caused thr nt*tdb files from 3.0.13 to be overwritten or lost.
In fact, I don't believe I changed the printing code at all 
between those 2 releases.
Comment 3 Gerald (Jerry) Carter 2005-05-30 19:48:26 UTC
Michael, can you send me copies of the original tdb files?
If not, it will be pretty hard to follow up on this report.
Comment 4 Michael Arlt 2005-06-20 01:16:41 UTC
Created attachment 1279 [details]
Comment 5 Michael Arlt 2005-06-20 01:19:16 UTC
Created attachment 1280 [details]
Comment 6 Michael Arlt 2005-06-20 01:20:01 UTC
Created attachment 1281 [details]
Comment 7 Gerald (Jerry) Carter 2005-07-15 10:48:36 UTC
I can't come up with any explanation of this.
I checked and there are no differences between the
printing code in these 2 releases.  Neither in the backend
nor in the rpc printing code.  All of the printer jeys appear
to be in the ntprinters.tdb file you uploaded.

Is there any additional information you could think of to 
give me some ideas of where else to look?
Comment 8 Pavel Juran 2005-07-29 00:43:19 UTC
I have upgraded to 3.0.14a from 3.0.13 two days ago and I have similar problems
since then.

We have 24 printers configured and overnight some of the printers got their
settings reseted (including printer driver, security ACLs, comments, paper and
tray settings, etc.). The first night it happened to 21 printers, today to 23 of

The files ntdrivers, ntforms and ntprinters do not seem to have been changed
(but I can't say that for sure). What I am sure has changed are the printer tdb
files in directory /var/lib/samba/printing, where the printers with lost
settings have their tdb files newly created (it seems like that happened when
someone printed something to the printer for the first time this morning). The
one printer that has preserved its settings has the tdb file about a year old.

I am going to downgrade back to 3.0.13 today as I am on holiday next week. After
that I will be available for further comments.
Comment 9 Gerald (Jerry) Carter 2005-09-27 09:32:15 UTC
I think this might be related to some of the mmap() failures 
people have reported.
Comment 10 Gerald (Jerry) Carter 2005-09-27 12:10:28 UTC

*** This bug has been marked as a duplicate of 3101 ***