Bug 2660 - Can't become connected user!
Can't become connected user!
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.14a
x86 Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-27 09:36 UTC by udo
Modified: 2005-08-24 10:27 UTC (History)
0 users

See Also:


Attachments
The strace. I hope it helps to show what is wrong. A setup problem or a real bug... (26.17 KB, application/octet-stream)
2005-07-05 08:02 UTC, udo
no flags Details
Debuglevel=10 log (120.84 KB, application/octet-stream)
2005-07-06 20:28 UTC, udo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description udo 2005-04-27 09:36:26 UTC
When I save a file on a FC3 samba 3.0.11-6 box I get in my messages:

Apr 27 18:32:23 epia smbd[3107]: [2005/04/27 18:32:23, 0]
smbd/service.c:make_connection_snum(567)
Apr 27 18:32:23 epia smbd[3107]:   Can't become connected user!
Apr 27 18:32:24 epia smbd[3107]: [2005/04/27 18:32:24, 0]
smbd/service.c:make_connection_snum(567)
Apr 27 18:32:24 epia smbd[3107]:   Can't become connected user!
Apr 27 18:32:24 epia smbd[3107]: [2005/04/27 18:32:24, 0]
smbd/service.c:make_connection_snum(567)
Apr 27 18:32:24 epia smbd[3107]:   Can't become connected user!

This is with a very basic smb.conf:

[global]
        workgroup = bla
        server string = VIA Epia Samba Server
        interfaces = 192.168.xx.0/24, 127.0.0.1/8
        bind interfaces only = Yes
        log level = 1
        log file = /var/log/samba/%m.log
        max log size = 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        printcap name = /etc/printcap
        os level = 56
        preferred master = Yes
        domain master = Yes
        dns proxy = No
        wins support = Yes
        ldap ssl = no
        remote announce = 192.168.xx.255
        valid users = udo, root
        hosts allow = 192.168.xx., 127.

[homes]
        comment = Home Directories
        read only = No
        browseable = No

[data]
        comment = Data
        path = /usr/local/data
        valid users = udo
        read only = No
        create mask = 0760

[data2]
        comment = Data2
        path = /usr/local/data2
        username = udo
        valid users = udo
        read only = No
        create mask = 0760

Stuff works OK, messages are annoying. Messages appear in older versions as
well. Lots of similar complaints on the web.
Comment 1 udo 2005-06-28 08:26:55 UTC
Upgraded to Fedora Core 4 with Samba 3.0.14a-2 and custom kernel version 2.6.12.1.
The error now looks like:

Jun 28 17:01:37 epia smbd[27734]: [2005/06/28 17:01:37, 0]
smbd/service.c:make_connection_snum(577)
Jun 28 17:01:37 epia smbd[27734]:   Can't become connected user!
Comment 2 Gerald (Jerry) Carter 2005-06-28 09:03:04 UTC
Are any selinux settings enabled perhaps ?
Comment 3 udo 2005-06-28 11:04:42 UTC
(In reply to comment #2)
> Are any selinux settings enabled perhaps ?

We boot with selinux=0. (although there is selinux in the kernel for later
experiments)
Comment 4 Gerald (Jerry) Carter 2005-07-04 06:46:41 UTC
Try running 'strace smbd -d 0 -i 2>&1 > logfile'
and connect using smbclient.
Comment 5 udo 2005-07-05 08:02:45 UTC
Created attachment 1294 [details]
The strace. I hope it helps to show what is wrong. A setup problem or a real bug...

The strace asked for. I used window to connect since that's what I use as
client.
Comment 6 Gerald (Jerry) Carter 2005-07-06 08:12:01 UTC
the satrec didn't shoiw what I hoped.  Can't you attach a level 10 
debug log surrounding the error messages?
Comment 7 Gerald (Jerry) Carter 2005-07-06 08:49:07 UTC
Did you see this mail?  I know I already asked about this
but perhaps it applies.

http://marc.theaimsgroup.com/?l=samba&m=112058027926933&w=2
Comment 8 udo 2005-07-06 10:32:40 UTC
We boot with selinux=0 so it is turned off completely, AFAIK. (like I posted before)
I could try to build a kernel completely without selinux which should yield same
results if I am right.
Comment 9 udo 2005-07-06 20:28:34 UTC
Created attachment 1296 [details]
Debuglevel=10 log
Comment 10 Volker Lendecke 2005-07-06 23:45:49 UTC
Ok, move the 'valid users' from [global] to each individual share. Or add 

[ipc$]
valid users = udo root nobody

ipc$ needs to be accessible anonymously.

Volker
Comment 11 udo 2005-07-07 07:24:39 UTC
Thanks, will test the IPC$ thing out!
Comment 12 udo 2005-07-09 03:59:08 UTC
Volker's comment works very well:

Ok, move the 'valid users' from [global] to each individual share. Or add 

[ipc$]
valid users = udo root nobody

ipc$ needs to be accessible anonymously.



So the problem is fixed.
(question is how samba could function without the fix?)
Comment 13 Gerald (Jerry) Carter 2005-08-24 10:27:31 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.