Bug 264 - ldapsam fails in profile_path expansion %g or %G read root's one instead
ldapsam fails in profile_path expansion %g or %G read root's one instead
Status: RESOLVED DUPLICATE of bug 208
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.0preX
Other other
: P1 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-02 04:23 UTC by Ignacio Coupeau
Modified: 2005-02-07 08:41 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ignacio Coupeau 2003-08-02 04:23:38 UTC
if in the smb.conf the profile path is setting to "\\%L\profiles\%g the profiles
from "root" are readed *instead* the users'one.

Assume that the uidNumber is 20038 ("999999-9") and the groupNumber is 202
("prn1") and the server name is bilbo (%L).

in the routine init_sam_from_ldap() a extra debug at pdb_set_profile_path like:
  DEBUG(0, ("init_sam_from_ldap: %s, %s, %d, %d\n",lp_logon_path(),
profile_path, uid, gid));
 
shows in the log:
[2003/08/02 20:59:59, 0] passdb/pdb_ldap.c:init_sam_from_ldap(664)
  init_sam_from_ldap: \\%L\profiles\%g, , -1, 0

so the group is 0 (root) and the uid is -1 instead 20038

and in 
passdb/pdb_get_set.c| pdb_set_profile_path() routine, the log says:

[2003/08/02 20:59:59, 10] passdb/pdb_get_set.c:pdb_set_profile_path(720)
  pdb_set_profile_path: setting profile path \\bilbo\profiles\root

when *must* be "\\bilbo\profiles\prn2"

This is related to 208 in beta2.
Comment 1 Gerald (Jerry) Carter 2003-08-06 11:09:19 UTC

*** This bug has been marked as a duplicate of 208 ***
Comment 2 Gerald (Jerry) Carter 2005-02-07 08:41:35 UTC
originally reported against 3.0.0beta3.  CLeaning out 
non-production release versions.