Bug 2636 - Samba hangs randomly while opening Photoshop PSD files
Samba hangs randomly while opening Photoshop PSD files
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.10
x86 Windows 2000
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-21 08:49 UTC by Michel van der Breggen
Modified: 2006-04-08 23:11 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel van der Breggen 2005-04-21 08:49:39 UTC
We run Samba 3.0.10 on Fedora Core 2. Every once in a while a file from 
photoshop can't be opened thru samba. Although it can be opened with the unix 
fs. When we gzip the file nothing is wrong and it can be send over the network 
again. Our designer has this problem on his machine, but when anybody else also 
tries to open the file they have the same problem. 

The log of samba says that the networkconnection has been resetted, but that is 
something that samba does (because only the file that locks has the problem and 
with all machines that try to open the file)

Samba log says this:

[2005/04/21 17:35:35, 2] smbd/open.c:open_file(245)
  bas opened file Projecten/CMS_3/Design/parts/splash_img.psd read=Yes write=No 
(numopen=8)
[2005/04/21 17:35:35, 2] smbd/close.c:close_normal_file(270)
  nobody closed file Projecten/CMS_3/Design/parts/splash_img.psd (numopen=7)
[2005/04/21 17:35:35, 2] smbd/open.c:open_file(245)
  bas opened file Projecten/CMS_3/Design/parts/splash_img.psd read=Yes write=No 
(numopen=8)
[2005/04/21 17:35:35, 2] smbd/close.c:close_normal_file(270)
  nobody closed file Projecten/CMS_3/Design/parts/splash_img.psd (numopen=7)
[2005/04/21 17:35:35, 2] smbd/open.c:open_file(245)
  bas opened file Projecten/CMS_3/Design/parts/splash_img.psd read=Yes write=No 
(numopen=8)
[2005/04/21 17:36:52, 0] lib/util_sock.c:read_socket_data(384)
  read_socket_data: recv failure for 4. Error = Verbinding door partner opnieuw 
ingesteld
[2005/04/21 17:36:52, 2] smbd/server.c:exit_server(571)
  Closing connections
[2005/04/21 17:36:52, 1] smbd/service.c:close_cnum(836)
  bas2 (192.168.1.12) closed connection to service bas
[2005/04/21 17:36:52, 1] smbd/service.c:close_cnum(836)
  bas2 (192.168.1.12) closed connection to service Data
[2005/04/21 17:36:52, 2] smbd/close.c:close_normal_file(270)
  nobody closed file Projecten/CMS_3/Design/parts/splash_img.psd (numopen=7)
[2005/04/21 17:36:52, 1] smbd/service.c:close_cnum(836)
  bas2 (192.168.1.12) closed connection to service Data
[2005/04/21 17:36:52, 2] smbd/close.c:close_normal_file(270)
  bas closed file mail/cleanup.log (numopen=3)
[2005/04/21 17:36:52, 2] smbd/close.c:close_normal_file(270)
  bas closed file mail/Pop3uidl.dbx (numopen=2)
[2005/04/21 17:36:52, 2] smbd/close.c:close_normal_file(270)
  bas closed file mail/Folders.dbx (numopen=1)
[2005/04/21 17:36:52, 2] smbd/close.c:close_normal_file(270)
  bas closed file mail/Offline.dbx (numopen=0)
[2005/04/21 17:36:52, 1] smbd/service.c:close_cnum(836)
  bas2 (192.168.1.12) closed connection to service bas
Comment 1 Jeremy Allison 2005-04-26 17:29:24 UTC
I'm guessing this error means :

read_socket_data: recv failure for 4. Error = Verbinding door partner opnieuw 
ingesteld

the client closed the connection on us. This is usually due to network hardware
problems. Can you translate this error message to English for me please ?

Jeremy.
Comment 2 Michel van der Breggen 2005-04-27 01:50:58 UTC
the error Verbinding door partner opnieuw ingesteld.

means Connection reset by peer. 
And this isn't an hardware issue, if it was than only one pc should have the 
problem or the problem should also accure at other network connections at the 
same time. But if a file won't open it won't open an all computers that try to 
access it, and it only accures with photoshop files, though I also read reports 
on the internet that people have the same problem with word files. I am still 
trying to refind the forum I found the messages on.

When they start yelling at me again about files that don't open i will upload 
one here for testing.
Comment 3 Jeremy Allison 2005-04-27 10:08:31 UTC
"Connection reset by peer" means the client just dropped the connection and sent
a RST packet when we resent data. It either means a network hardware problem or
a problem in the client TCP stack. There are *no* other options - that's what
this error message means.

There's nothing in the Samba code that is causing this.

Jeremy.
Comment 4 Michel van der Breggen 2005-04-27 10:47:16 UTC
if it was a hardware error it would not also occure on other computers and 
only with specific files. The files wouldn't be copyable with an nfs client 
either but they are. If it is a reset like you say, it is caused by the fact 
that samba locks up the line without finishing the conversation. The clients 
are all win2k machines and there is nothing wrong with their TCP stack.

My guess is that it is caused by a binary combination that for some reason 
makes samba choke. Like i said when they start complaining about a file again 
i will post it here for verification.

Comment 5 Jeremy Allison 2005-04-27 11:12:04 UTC
"if it was a hardware error it would not also occure on other computers" - not
neccessarily - it could be a switch/hub problem.

"The files wouldn't be copyable with an nfs client 
either but they are."

Also not true. NFS uses UDP (connectionless transport). SMB uses TCP and
requires stream (continuous) connectivity. NFS survives bad networks much better
than SMB.

"If it is a reset like you say, it is caused by the fact 
that samba locks up the line without finishing the conversation."

No, you don't understand. Samba is not "locking up". THE CLIENT IS DROPPING THE
TCP CONNECTION. The important word here is ****"CLIENT"****. All Samba (the
server) is doing is reporting to you that the client dropped the connection. We
know nothing more.

Jeremy.
Comment 6 Gerald (Jerry) Carter 2006-04-08 23:11:15 UTC
closing.  no response.