Bug 2633 - Samba's SPNego causes interrupted operation
Samba's SPNego causes interrupted operation
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.2
x86 Windows XP
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-20 06:44 UTC by Mohammed Khallaf
Modified: 2006-04-08 11:39 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mohammed Khallaf 2005-04-20 06:44:23 UTC
This version of Samba uses SPNego by default. This is bad, because Microosft's
implementation is different. If an NT-Based Windows user opens a Samba share
(using User Mode for Samba), and then tries to open another windows for the same
share and browse throgh it, the first window will give an error immediately. The
same goes for setup or file transfer over network, both will terminate with an
error indicating that the share no longer exists. The problem is with Samba's
SPNego. I think that Samba's SPNego is more secure, it checks for credentials
every while, but that does not suit Windows, as it closes all previous sessions
with the same Samba share.
Comment 1 Gerald (Jerry) Carter 2005-04-20 06:56:00 UTC
I cannot reproduce any behavior similar to what you describe.
Please provide more details.  Windows NT 4 doesn't support 
SPNEGO anyways.
Comment 2 Mohammed Khallaf 2005-04-24 03:21:54 UTC
Well, the problem happened with me like this:
1- I was using Mandrake Linux 10.0's Samba.
2- Three network shares were created. If you want the conf. file, I can list it.
3- While I was installing the Win32 TeX system - MikTeX - OVER NETWORK on windows 
   XP, the setup was interrupted with the error produced from the MikTeX  
   installer stating that some file cannot be opened. The same thing happened over 
   and over, even though the shared folder where MikTeX files are was still 
   seemlessly accessible "no username or password required as they are the same as 
   Samba's".
4- I tried to manipulate every setting that related to timeouts or 
   re-establishment of the session, but nothing changed.
5- Even more, if the setup is running - let's say - from \\pc\sh1 and I try to 
   open the RUN dialogue box in Windows XP or Windows 2000 and enter \\pc\sh2, 
   the setup stops immediately with the file not found error. The same thing 
   happens even if it is the same share - \\pc\sh1.
6- The only way things were back to normal is when I disabled SPNego. That's 
   all.

Thank you,
Mohammed Khallaf
Comment 3 Gerald (Jerry) Carter 2005-04-24 04:19:53 UTC
Please attach a level 10 smbd debug log and an 
ethereal trace.  However, if this really is a bug 
filed against Samba 3.0.2, please retest against 
3.0.11 or later (the latest SAMBA_3_0 svn tree would 
be good as well) to ensure you can reproduce the behavior
against the current code.  3.0.2 is really old.
Comment 4 Gerald (Jerry) Carter 2006-04-08 11:39:10 UTC
closing.  Fixed in current releases I expect with the rpc rewrite in 3.0.21