Bug 2632 - smbclient failed to tar directories
smbclient failed to tar directories
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.20
x86 Windows 2000
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-20 06:34 UTC by spurnelle
Modified: 2006-04-08 07:43 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description spurnelle 2005-04-20 06:34:27 UTC
Last week I activate some script that use smbclient on my test server (RedHat EL 3).
But when this script run, the kernel make a panic and display a Out of Memory (OOM).
If I look the content of my file, it's contains X copies of same directory.

The same script run fine with samba 3.0.11
The client is a windows 2000 workstation SP4.

The share contain 3 direcory and the size of the tar file must be 1.4Gb.
Now, when the script run (3.0.13, 3.0.14a, 3.0.15pre2) the file is build
correctly until 1.2Gb and after, the CPU utilization increase over 50% (normally
17%) and the memory usage to.

Personnaly, I think that is a findNext() loop problem.
Comment 1 Jeremy Allison 2005-04-25 15:58:38 UTC
What server is this smbclient tar command running against ? Is this repeatable ?
If so, can you get me an ethereal or tcpdump capture trace from the network please ?

Thanks,

Jeremy.
Comment 2 spurnelle 2005-04-26 10:58:37 UTC
The smbclient run on a RedHAt Enterprise Linux 3 ES
It's repeatable

The ethereal output is available here : 
http://www.linuxplusvalue.be/download/smbclient.tar.gz

It's a tar.gz file because the pcap file have a big size > 40 Mo
The share containt a copy of a database.  I have no possibility to change the
extension.
Comment 3 Jeremy Allison 2005-05-01 05:28:36 UTC
I downloaded and took a look at this capture file. Unfortunately it is useless
as you have only captured one side of the conversation (the requests). There are
no replies in this trace so it's impossible to see why the client keeps asking
for the same file.
Please send me the complete trace.
Thanks,
Jeremy.
Comment 4 Jeremy Allison 2005-05-01 05:29:25 UTC
You also neglected to tell me what Windows server verion (OS and service pack
level) you are running smbclient against. If you give me the full information I
ask for it'll help me fix your problem much more quickly.
Jeremy.
Comment 5 spurnelle 2005-05-02 04:32:47 UTC
(In reply to comment #4)
> You also neglected to tell me what Windows server verion (OS and service pack
> level) you are running smbclient against. If you give me the full information I
> ask for it'll help me fix your problem much more quickly.
> Jeremy.
> 

It's on my first post : 
The client is a windows 2000 workstation SP4.

For more precisions : 
Windows 2000 Workstation, (Numero 2195), Service Pack 4
Comment 6 Jeremy Allison 2005-05-02 06:10:50 UTC
Sorry for being sharp in the reply, I'm claiming jet-lag was at fault (I'm in
Germany at the moment). Please accept my apologies. Could you please get me the
network trace showing both requests and replies ? That would help a lot as I'm not
in a position to try and reproduce this at the moment.
Thanks,
Jeremy
Comment 7 spurnelle 2005-05-02 06:29:07 UTC
(In reply to comment #6)
> Sorry for being sharp in the reply, I'm claiming jet-lag was at fault (I'm in
> Germany at the moment). Please accept my apologies. Could you please get me the
> network trace showing both requests and replies ? That would help a lot as I'm not
> in a position to try and reproduce this at the moment.
> Thanks,
> Jeremy

I know you participate to SambaXP and I accept your apologies.
For the output of the ethereal, this take some times because the network where I
work, the traffic is very slow and the file have a very big size : 1 Gb.
Compressed (zip or tar.gz) : 112Mb.  
It's very a large file.  I must take my USB-keys and put on for transfer the
file to my home-PC.  And after, put-it on my web-site or on other uploadable site.  

Maybe tomorrow or later.

Comment 8 spurnelle 2005-05-03 13:08:47 UTC
(In reply to comment #7)

The file is available, the file can be downloaded at
http://www.linuxplusvalue.be/download/smbclient2.tar.gz

The file have a size of 112Mo and after uncompress, 959Mo

Happy sambaXP in germany
Comment 9 spurnelle 2005-06-27 03:04:14 UTC
With samba 3.0.20-pre1, the problem seem to be solved.
Maybe, it's the BUG 2698 which resolve the problem.
Comment 10 Gerald (Jerry) Carter 2005-06-27 05:44:39 UTC
Thanks for the feedback.  Marking this one as fixed.
Comment 11 Gerald (Jerry) Carter 2005-08-24 10:27:06 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 12 Gerald (Jerry) Carter 2006-04-08 07:43:41 UTC
Cleaning up versions.  There was no 3.0.15 so leaving it in bugzilla 
is causing some confusion.  Moving these nuder 3.0.20.
Originally files against 3.0.15preX.