Bug 2598 - exclude_dir option doesn't exclude subdirectories
exclude_dir option doesn't exclude subdirectories
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.12
x86 FreeBSD
: P3 minor
: none
Assigned To: Holger Hetterich
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-12 14:25 UTC by Kevin Kobb
Modified: 2010-02-25 08:20 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Kobb 2005-04-12 14:25:51 UTC
When specifying a directory in the exclude_dir option, files deleted from
subdirectories of the excluded directory are sent to the recycle location instead.

For example if exclude_dir = dir1, files deleted from dir1 are not sent to
recycle location. If you have dir1/dir2, files deleted from dir2 are recycled
not excluded.
Comment 1 Holger Hetterich 2010-02-16 09:36:50 UTC
Can you please check if this works with samba 3.4.5 ?

I am unable to reproduce this on 3.4.5 and current master:

[2010/02/16 16:31:07.792243, 10] modules/vfs_recycle.c:554(recycle_unlink)
  recycle: base = vfs_smb_traffic_analyzer.c
[2010/02/16 16:31:07.792261, 10] modules/vfs_recycle.c:123(recycle_exclude)
  recycle: exclude =  ...
[2010/02/16 16:31:07.792280, 10] modules/vfs_recycle.c:134(recycle_exclude_dir)
  recycle: exclude_dir = dir1 ...
[2010/02/16 16:31:07.792300,  3] modules/vfs_recycle.c:563(recycle_unlink)
  recycle: directory dir1/dir2 is excluded
[2010/02/16 16:31:07.792374, 10] smbd/notify_internal.c:886(notify_trigger)
  notify_trigger called action=0x2, filter=0x1, path=/pool/dir1/dir2/vfs_smb_traffic_analyzer.c
Comment 2 Holger Hetterich 2010-02-25 06:47:00 UTC
3.0 is in maintenance mode, and this works on 3.4.6.

I am closing this as WORKSFORME, feel free to reopen the bug if
you think different.
Comment 3 Kevin Kobb 2010-02-25 08:20:20 UTC
Tried this on 3.4.5 and it seems to work fine now.

Thanks.