Bug 2595 - Cannot view more than 2100 windows computers in an AD workgroup
Cannot view more than 2100 windows computers in an AD workgroup
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: net utility
3.0.7
PPC Mac OS X
: P3 normal
: none
Assigned To: James Peach
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-12 04:06 UTC by Tom Hayes
Modified: 2007-04-07 15:47 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Hayes 2005-04-12 04:06:00 UTC
When running os x 10.3.8 and OS X server 10.3.8, I cannot view more than 2100 windows computers at 
any one time, in any one AD workgroup. I believe this bug is also present in OS X 10.4. The particular 
workgroup I want to view, contains more than 2500 computers. 
The computers are listed in the workgroup 1 to A to Z. Typically I only see computers named up to the 
mid "S's". However as computers are switched off at the end of the day, I get to see the end of the list, 
i.e. computers whose names start with "Z".

If it is of any help, when DAVE (Thursby systems) is installed and running, I can see all of the computers 
in the workgroup.
Comment 1 Jim McDonough 2005-05-19 04:36:34 UTC
I'm not sure where in this picture you have Samba, and what it means in terms of
OS X to "view computers in a workgroup".  This may just be my lack of Mac
knowledge, but I'll have to ask for more details on how Samba is involved in this.

Next, if it is a Samba server that is causing the problem, some traces will be
needed, perhaps from ethereal or samba logs.  Can you get me more info on this
and post it here?
Comment 2 Tom Hayes 2005-05-20 02:42:06 UTC
Hi,
Please correct me if I am incorrect in teh following:
I understand that Apple use your version of SAMBA in their operating system as a means of browsing a 
windows network. Within our domain we have a number of workgroups. Now the version of SAMBA built 
into OS X Tiger (and Panther I think) is version 3.0.7.
I have discovered that, if a workgroup contains more than 2100 computers in the windows workgroup, 
the maximum number of computers I will be able to see is 2100. e.g. we have one windows workgroup 
that contains at any one time between 2500 and 3000 computers. If I use the version of SAMBA in OS X 
to view this workgroup, the maximum number of computers I can see is 2100. 
I understand that Apple say a user should be able to see 2500, but if the number of computers in the 
workgroup exceeds 2500, you will not be able to see the other computers. I hope you can follow what I 
am trying to explain.
I understand that Apple say the bug is in SAMBA.
 
Comment 3 Tom Hayes 2005-05-23 04:03:54 UTC
Can you let me know what you need subsequently and I will do  my best to give you as much 
information as possible.
Comment 4 Jim McDonough 2006-04-05 22:03:29 UTC
Sorry, it's been a while.  What I need to know is how you're determining that samba is doing this.  Is this an apple gui?  Or a command?  Perhaps apple is linking in libsmbclient?  I'm not sure, as I don't have a mac to try this on..
Comment 5 Tom Hayes 2006-04-06 06:17:10 UTC
Hi , thanks for getting back to me. The issue is still there under OS X 10.4.x. In a way I am guessing that it is a samba issue, but I have reported it to apple as well. You probably would need a mac to check it to see if teh bug is with samba. If you wish tell me what I need to do (as detailed as possible) to check if it is  sabma issue.

(In reply to comment #4)
> Sorry, it's been a while.  What I need to know is how you're determining that
> samba is doing this.  Is this an apple gui?  Or a command?  Perhaps apple is
> linking in libsmbclient?  I'm not sure, as I don't have a mac to try this on..
> 
Comment 6 Gerald (Jerry) Carter 2006-04-20 08:03:32 UTC
severity should be determined by the developers and not the reporter.
Comment 7 James Peach 2006-11-23 01:01:40 UTC
Jim, do you want to reassign this to me?
Comment 8 Jim McDonough 2006-11-23 05:55:18 UTC
Reassigning to James as requested
Comment 9 James Peach 2007-04-07 15:47:39 UTC
Fixed in 10.5.