Bug 2586 - "." and ".." shows up as folders without name
"." and ".." shows up as folders without name
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.13
Other Windows XP
: P3 minor
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-09 03:17 UTC by Øyvind Repvik
Modified: 2005-06-25 23:45 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Øyvind Repvik 2005-04-09 03:17:44 UTC
When mounting a share in Windows, two folders show up in the share without
names. The share is empty (except "." and "..") on the linux side, so I assume
it's those two folders that show up. They cannot be deleted, and nothing happens
when I try to enter them. 

Samba is compiled against uClibc on bigendian ARM.
Comment 1 Gerald (Jerry) Carter 2005-04-20 06:37:43 UTC
The parent (..) and current (.) directories show 
up when displaying a directory listing on a remote 
Windows server as well.  No bug here as far
as I can tell.
Comment 2 Øyvind Repvik 2005-04-20 07:56:12 UTC
(In reply to comment #1)
> The parent (..) and current (.) directories show 
> up when displaying a directory listing on a remote 
> Windows server as well.  No bug here as far
> as I can tell.

Yeah, but do they show up in Explorer as well? And without names?
When mounting the share as a drive, and doing a "dir", it lists two folders with
no name. If they were named "." and ".." it'd be understandable...

I am unable to reproduce this behaviour when using samba on a x86 linux-box.
(But both with glibc and uClibc on ARM hardware)
Comment 3 Gerald (Jerry) Carter 2005-04-20 08:27:58 UTC
Can you attach an ethereal trace of the failure ?  Thanks.
I don't have access to this particular environment.
Comment 4 Jeremy Allison 2005-06-10 18:13:44 UTC
I'm guessing this is due to the problem with a WinNT 4.x client where the . and
.. directories have to be seen first in a file listing. I've just fixed this in
the current SAMBA_3_0 and HEAD SVN code. Will be fixed in the next release.
Can you confirm that you're using an NT 4.x client ? 
Jeremy.
Comment 5 Øyvind Repvik 2005-06-10 19:22:10 UTC
I'm using Windows XP with all updates. 
Comment 6 Jeremy Allison 2005-06-10 20:04:01 UTC
Well I only checked NT4 and W2K3, maybe XP has the bug too. I'm guessing if you
look at your log you'll find . and .. not being returned as the first too
entries of the directory. This bug was fully reproducible with the earlier code
and 100% gone with the latest code in SVN, so I'm guessing this is fixed in the
current tree.
Jeremy.
Comment 7 Øyvind Repvik 2005-06-24 21:30:43 UTC
I've just compiled samba-3.0.14a (glibc, armeb). None of the folders or files
show up with names at all in shares. If I try to mount it from another linux-box 
(mount -t cifs //10.0.0.44/repvik /mnt -o username=xxx) and do a listing, I get
this:

fs mnt $ ls -als
ls: : No such file or directory
ls: : No such file or directory
ls: : No such file or directory
ls: : No such file or directory
ls: : No such file or directory
ls: : No such file or directory
total 0

Mounting the same share in Windows XP, I see 6 folders. It is actually 3 folders
and 3 files. If I create a new folder it shows up without name. It is created
correctly though. If I create a new file, it shows up as a nameless folder as well.

Unfortunately I can't (as of yet) compile ethereal for this box in particular.
Comment 8 Øyvind Repvik 2005-06-25 23:45:37 UTC
Not a bug. Result of silly overloading of configure overrides in cross compile
environment (OpenEmbedded). Sorry for the inconvenience.