Bug 2580 - inconsitent value of %m
inconsitent value of %m
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.11
Sparc Solaris
: P3 critical
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-06 13:57 UTC by Joerg Moellenkamp
Modified: 2005-04-20 06:52 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joerg Moellenkamp 2005-04-06 13:57:09 UTC
Script is used to create system- and locationspecific profile-directory(and some additional directories) 
on the fly. When used in conjunction with interdomain-trusts the %m in logon-path ist resolved to the 
trusted domain controller (unwanted behaviour) and the %m in root preexec ist resolved to the name of 
the windows-client (wanted behaviour).

 logon path = \\%L\profiles\%U\%m
 root preexec = <script> '%m' '%U' '%a' '%L'
Comment 1 Gerald (Jerry) Carter 2005-04-20 06:40:08 UTC
This is by design from what I can tell.  The logon path is executed
as part of the net_sam_logon() reply which is sent to the trusted 
domain controller.  The preexec script is done when the client 
connects to an actual share.  Not a bug per say.
Comment 2 Joerg Moellenkamp 2005-04-20 06:52:39 UTC
(In reply to comment #1)
> This is by design from what I can tell.  The logon path is executed
> as part of the net_sam_logon() reply which is sent to the trusted 
> domain controller.  The preexec script is done when the client 
> connects to an actual share.  Not a bug per say.

Perhaps not a bug, but this renders %m useless for logon path, as all logon paths would be contain the 
domain controller instead of the client in case of an interdomain trust