Bug 2545 - oplock break timed out after 30 seconds
oplock break timed out after 30 seconds
Status: RESOLVED DUPLICATE of bug 2532
Product: Samba 3.0
Classification: Unclassified
Component: File Services
x86 Windows XP
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-03-24 03:42 UTC by Thomas Lucke
Modified: 2005-03-24 06:22 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lucke 2005-03-24 03:42:58 UTC
We have installed 300 Samba 3.0.6 Server as Fileserver as Workgroup Server , to 
share Word and Access files for Windows XP SP1 . In some cases the following 
error occures:

File Server stops responding for ca. 30-60 sek. At this time we have following 
logfile :

[2005/04/13 19:18:11, 0] smbd/oplock.c:oplock_break(841)
  oplock_break: receive_smb timed out after 30 seconds.
  oplock_break failed for file Vorlagen/Adreßköpfe/NORMAL.DOT (dev = 303, inode 
= 392881, file_id = 17013).
[2005/04/13 19:18:11, 0] smbd/oplock.c:oplock_break(913)
  oplock_break: client failure in oplock break in file 
[2005/04/13 19:18:11, 0] smbd/reply.c:reply_lockingX(4629)
  reply_lockingX: Error : oplock break from client for fnum = 13075 and no 
oplock granted on this file (Vorlagen/Adreßköpfe/NORMAL.DOT).

We can reproduce this erorr with a special set of own Word Templates, when we 
create a new Word file. After this error the network perfomance seams to be 
poor (Redirector turn off the oplock / cache ) until you reboot the windows 
machine. In your test-lab the updated samba 3.0.11 server have the same 
problem. In all this cases when the error occurs , I permit the network is fine 
and we can see the error if only one client is working. 

See also BUG 1801
Comment 1 Gerald (Jerry) Carter 2005-03-24 06:22:37 UTC
please don't file the same bug twice.  Thanks.

*** This bug has been marked as a duplicate of 2532 ***