Bug 2542 - Windows Me Explorer File System Access Locks Up
Windows Me Explorer File System Access Locks Up
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.13
x86 Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-24 00:38 UTC by John H Terpstra
Modified: 2005-03-28 21:07 UTC (History)
0 users

See Also:


Attachments
Level 10 log file that demonstrates the lock-up problem. (219.69 KB, application/x-bzip)
2005-03-24 00:40 UTC, John H Terpstra
no flags Details
The smb.conf file in use during this test. (2.41 KB, application/octet-stream)
2005-03-24 00:43 UTC, John H Terpstra
no flags Details
Network Capture (487.33 KB, application/octet-stream)
2005-03-24 18:48 UTC, John H Terpstra
no flags Details
Samba log file created during Ethereal capture. (573.97 KB, application/octet-stream)
2005-03-24 18:57 UTC, John H Terpstra
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description John H Terpstra 2005-03-24 00:38:03 UTC
Windows Me is a domain logon client. Simply by logging onto the network, then
using Windows Explorer to browse to the media share, then through to a
sub-directory that contains 816 files causes Windows Me to lock-up completely.

Samba appears to enter an endless loop just after the list of files has been
brought up in Explorer.

The attached are a level 10 log and the smb.conf file. The source is the
pre-release tarball for Samba-3.0.13 provided by Jerry Carter.
Comment 1 John H Terpstra 2005-03-24 00:40:38 UTC
Created attachment 1107 [details]
Level 10 log file that demonstrates the lock-up problem.
Comment 2 John H Terpstra 2005-03-24 00:43:20 UTC
Created attachment 1108 [details]
The smb.conf file in use during this test.

The Windows Me client is called: MAGGOT
The Domain is: MIDEARTH
The Samba server is: FRODO

The Samba host server is SuSE Professional 9.1. The Samba 3.0.13 RPM was built
using a slightly modified update of the SerNet SRPM.
Comment 3 Gerald (Jerry) Carter 2005-03-24 06:14:01 UTC
John,  I can't reproduce this at all.  Your Windows ME box 
has always been a little flakey.  You sure it's not just WinME
again ?
Comment 4 John H Terpstra 2005-03-24 18:48:20 UTC
Created attachment 1115 [details]
Network Capture

I repeated the operation to generate this capture.
Sequence was:
1. Open folder \\frodo\media\HymnTunes\By-Name\A
2. Play several MIDI tunes until lock-up occurred
3. Kill samba
4. stop ethereal
Comment 5 John H Terpstra 2005-03-24 18:57:39 UTC
Created attachment 1116 [details]
Samba log file created during Ethereal capture.
Comment 6 Jeremy Allison 2005-03-25 12:05:19 UTC
I don't see the server crashing in any of these traces. I see the client doing
amazingly stupid things, but that's not the server fault.
Jeremy.
Comment 7 John H Terpstra 2005-03-28 21:07:49 UTC
After looking at this Windows Me problem for many hours and seeing Windows 2000 
Professional and Windows XP Home and Windows XP Professional work without any 
problems I am drawn to the conclusion that this is a Windows Me bug. 
 
Why in goodness name Windows Me should go into hysterics is a question that 
demands more time than we can afford to throw at a version of Windows that is 
over-all problematic at best. No further time will therefore be invested in 
solving this issue - I dumped Windows Me and upgraded the machine in question 
to Windows XP Professional which is now as happy as a tom-cat. 
 
- John T.