Bug 2518 - Setting "printing = cups" in SWAT is IMPOSSIBLE.
Setting "printing = cups" in SWAT is IMPOSSIBLE.
Product: Samba 3.0
Classification: Unclassified
Component: SWAT
x86 Linux
: P3 minor
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-03-22 08:59 UTC by Greg Folkert
Modified: 2009-04-20 04:13 UTC (History)
1 user (show)

See Also:

smb.conf as written by SWAT. (3.02 KB, text/plain)
2005-03-22 09:54 UTC, Greg Folkert
no flags Details
Requested command to be run output (79 bytes, text/plain)
2005-03-22 09:56 UTC, Greg Folkert
no flags Details
Other requested command to be run output (1.33 KB, text/plain)
2005-03-22 09:57 UTC, Greg Folkert
no flags Details
My config.log of my configure run. (42.32 KB, text/plain)
2005-03-22 10:15 UTC, Greg Folkert
no flags Details
Full config.log compressed (42.32 KB, application/x-bzip)
2005-03-22 10:16 UTC, Greg Folkert
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Folkert 2005-03-22 08:59:26 UTC
I have been using swat for a really long time. This is the first I have
ever REALLY caught it doing something wrong.

In the latest version of SAMBA, with swat compiled at the same time
(with the explorer patch added afterward) I am fairly certain, I have
found and issue.

I am tooling along, I use swat to add a share. No problems, share works

About 10 minutes later, I start getting phone calls... about printing
failing. I try with my linux machine... no problems, cups is working,
must be samba.

Samba config looks fine to me, I restart it, still no printing. Well, I
get the people who MUST print now working using client side printing to
cups (not pretty on Win9X)

So, I start twiddling with the advanced printing area. Set to cups. misc
option... commands all look good. Commit.

Still no printers. I look at smb.conf. Hmmm, takes me about 3 minutes to
deduce the problem.

When SWAT wrote the smb.conf, set with printing = cups through SWAT, the
declaration is _*GONE*_. Since there is #No default# setting. All
printing goes away. I switch it to BSD temporarily... printing starts as
I have BSD print emul going to for a few legacy *NIX machines. I look at
the conf... it shows "printing = bsd" I think GREAT it just needed a
change, I wait for printing to catch up.

I use swat to change smb.conf to "printing = cups", printing falls over
again. Looking through smb.conf... the *IS* no "printing =" anymore. I
add it manually, restart samba. Voila We are good to go. Time to stay
away from Swat for a bit. Anytime you commit anything through SWAT it
removes the "printing = cups" unless it isn't set at "printing = cups"
then it leaves it.

This is a BIG pain. Any chance someone could look over it. I couldn't
find a problem with a cursory check (using grep and a few patterns I
sort of expected to find) and gained no insight.
Comment 1 Gerald (Jerry) Carter 2005-03-22 09:06:54 UTC
greg,  please post the output from the following commands and 
attach you smb.conf as well (but not inline).  

$ smbd -b | grep -i cups

$ testparm -v -s smb.conf | grep -i printing


And I'm sure you are aware that swat only writes out 
non-default settings.  So it's pretty important that you 
are using the version of swat that matches you smbd 
Comment 2 Greg Folkert 2005-03-22 09:54:11 UTC
Created attachment 1063 [details]
smb.conf as written by SWAT.

This is an original copy of the smb.conf as written by SWAT. There is not any
declaration "printing ="

This config makes printing impossible with SAMBA for Windows printing through
Comment 3 Greg Folkert 2005-03-22 09:56:37 UTC
Created attachment 1064 [details]
Requested command to be run output

Here is the needed output from:

smbd -b | grep -i cups
Comment 4 Greg Folkert 2005-03-22 09:57:34 UTC
Created attachment 1065 [details]
Other requested command to be run output

testparm -v -s /etc/samba/smb.conf | grep -i printing

Output from that command.
Comment 5 Greg Folkert 2005-03-22 10:04:29 UTC
Here are the files you requested:


If I ran the smb.conf, it makes printing via SAMBA impossible. Printers do not
get exported. Samba doesn't even check for them. There are no requests to the
CUPS client server running on the machine. I have a seperate print server
pushing all of its printers out to cups client machines. I have 5 Linux machine
as workstations and all 5 work proper. Print via CUPS from the SAMBA server
works fine as well. But, printing to SAMBA which should be passing the info
along to cups never happens. Because it can't initialize the printing device.
Windows9X->WindowsXP cannot even see the printers.

If you need my configure command line, I can provide it.

I seem to be able to workaround this with a manual edit... but what is the point
then? :-D
Comment 6 Greg Folkert 2005-03-22 10:15:23 UTC
Created attachment 1066 [details]
My config.log of my configure run.

This is the complete log of my configure run prior to compiling samba v3.0.12.
It is sent compressed as it is 1648KB in size uncompressed.
Comment 7 Greg Folkert 2005-03-22 10:16:50 UTC
Created attachment 1067 [details]
Full config.log compressed

Here it is for real this time.
Comment 8 Björn Jacke 2009-04-20 04:13:22 UTC
if cups support is compiled in then "cups" *is* the default for "printing". You should be aware that changing a value to its default by removing the setting from smb.conf (like swat does, too) this will only work for newly started smbd's. When swat removes the "printing" parameter when you switch to cups this is what's expected.