Bug 2516 - winbindd_group.c doesn't compile on Tru64 4.0
winbindd_group.c doesn't compile on Tru64 4.0
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.12
Alpha OSF/1
: P3 regression
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-22 07:19 UTC by Philippe Michel
Modified: 2005-08-24 10:17 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Michel 2005-03-22 07:19:38 UTC
winbindd_group.c doesn't compile on Tru64 4.0 due to the use of uint32_t type
around line 1250.

This looks like a typo since it does not seem to be used anywhere else (uint32
is). The following patch fixes the problem :

*** winbindd_group.c.orig       Fri Feb 25 18:59:30 2005
--- winbindd_group.c    Tue Mar 22 14:33:57 2005
***************
*** 1246,1252 ****
         * domain also asks for this info. -- vl */
  
        if (!IS_DC) {
!               uint32_t *alias_rids = NULL;
                int num_aliases;
  
                /* We need to include the user SID to expand */
--- 1246,1252 ----
         * domain also asks for this info. -- vl */
  
        if (!IS_DC) {
!               uint32 *alias_rids = NULL;
                int num_aliases;
  
                /* We need to include the user SID to expand */
Comment 1 Gerald (Jerry) Carter 2005-03-22 07:36:38 UTC
Thanks.  Fixed.
Comment 2 Gerald (Jerry) Carter 2005-08-24 10:17:19 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.